Oni Central Forum

A forum for the Oni community

You are not logged in.

#1 6/2/10 12:31

Morbeus
Member
Registered: 6/2/10

Sound trouble

Hi there.
So, a while ago I get a new computer and wonder how it'll run some older games. Remembering the fun I used to have with Oni, I decided to give that a try.

Now, I'd heard about issues it had with newer hardware, so a quick google search and I installed the C-Daodan dll and a modified .exe from here: http://wiki.oni2.net/Daodan_DLL
So, I cross my fingers and try and run it, and...sucess. It works. Except there's no sound. At all.

I'm using Windows 7, and have tried running Oni in both normal and Windows XP compatability modes. I don't have a sound card other than the onboard sound, and there don't seem to be any options ingame to modify.

So, here I am, wondering if you kind folk might have any advice?

Offline

#2 6/2/10 16:58

Tudorge
Member
From: Romania, Bucharest
Registered: 26/10/09
Website

Re: Sound trouble

* I played Oni without problems a few months after building my new computer, with Windows XP, without anything patched or modified.
I had an integrated sound problem too:
After i built and set up mine, the next day before school, i rushed to install half life 2 to see how it works. I was grateful that it was in excellent performance, really happy! But the sound didn't work from the start.
Tell me what motherboard do you have. I had a GIGABYTE GA-*forgotcode with dual bios, dual gigabit ethernet, dual channel capable all onboard. I finally enabled the sound using the BIOS, enabling Legacy Drivers, and disabling the other sound option.
While you use Microsoft Windows, try to see what motherboard model do you have via Device Manager.

Offline

#3 7/2/10 8:32

Morbeus
Member
Registered: 6/2/10

Re: Sound trouble

Well my motherboard is a Asus P5KPL-AM Intel G31 Chipset LGA775 FSB1066(OC)/667/800 DDR2 Mainboard, if I quote from the specs when I ordered it. Every other game I have works fine for sound, so it seems just ot be an Oni problem.

Offline

#4 7/2/10 9:39

demos_kratos
Member
From: Russia, Volzhskiy
Registered: 13/8/08

Re: Sound trouble

Here is my advice - use XP SP3 until Win7 SP1 is released. Otherwise there's no point. M$ has a habit to release hole-crapped systems before fixing all holes. (no offense, just personal experience)

Last edited by demos_kratos (10/2/10 10:27)


Jente, du er deilig, du er lekker, ihvertfall nå når jeg drikker.
Baby, du har det som trengs, hva er sannsynligheten for at vi to hopper til sengs?
Kan du si meg det? Jeg er ikke så stø i sannsynlighetsregning.

Offline

#5 7/2/10 13:18

Gumby
Member
From: Seattle, WA, USA
Registered: 30/8/07

Re: Sound trouble

demos_kratos wrote:

Here is my advice - use XP SP3 until Win7 SP1 is released. Otherwise there's no point. M$ has a habit to released hole-crapped systems before fixing all holes. (no offense, just personal experience)

Win7 is just fine.

1. Stop using "M$". It makes you sound like a troll.
2. I use Win7 every day and it works great.


Iritscen: roll
Iritscen: it's amazing this program even works
Gumby: i know
Iritscen: and that statement applies to my code, not just yours

Offline

#6 10/2/10 10:31

demos_kratos
Member
From: Russia, Volzhskiy
Registered: 13/8/08

Re: Sound trouble

Stop using "M$". It makes you sound like a troll.

OK, I'll try.

I use Win7 every day and it works great

Well, When I first installed it I found 2 really big bugs regarding the interface and 1 localization bug. Those 2 bugs should've been fixed by now but Start menu still looks too ugly in Russian ver.


Jente, du er deilig, du er lekker, ihvertfall nå når jeg drikker.
Baby, du har det som trengs, hva er sannsynligheten for at vi to hopper til sengs?
Kan du si meg det? Jeg er ikke så stø i sannsynlighetsregning.

Offline

Board footer

Powered by FluxBB