Oni Central Forum

A forum for the Oni community

You are not logged in.

#1 24/3/13 2:41

6opoDuJIo
Member

AE, WIN8, Fault - any ideas?

Tried to launch AE.
Got texture pack installed
contents of debugger.txt is:

[== Undefined ==]
Error 1 reported from File: F:\BungieDevelopment\BungieSource\OniProj\OniGameSource\Oni_GameSettings.c, Line: 46 (message follows)

Error 1 reported from File: F:\BungieDevelopment\BungieSource\OniProj\OniGameSource\Oni_Level.c, Line: 409 (message follows)

Error 1 reported from File: F:\BungieDevelopment\BungieSource\OniProj\OniGameSource\Oni.c, Line: 943 (message follows)

startup.txt content:

[== Undefined ==]
daodan attached
begin initializing oni
looking for the game data folder
initializing the template manager
DataFolder = GameDataFolder
Created a file iterator for the data folder.
Got Level Info for level0_Final.dat.
Valid Level level0_Final.dat
calling TMrRegisterTemplates
calling ONrRegisterTemplates
initializing oni platform specific code
initializing sound system 2, basic level
initializing basic sound system 2 layer...
DirectSoundCreate
direct sound dwFlags = f1f
direct sound dwFreeHw3DAllBuffers = 0
direct sound dwFreeHw3DStaticBuffers = 0
direct sound dwFreeHw3DStreamingBuffers = 0
direct sound dwFreeHwMemBytes = 0
direct sound dwFreeHwMixingAllBuffers = 0
direct sound dwFreeHwMixingStaticBuffers = 0
direct sound dwMaxContigFreeHwMemBytes = 0
direct sound dwMaxHw3DAllBuffers = 0
direct sound dwFreeHwMixingStaticBuffers = 0
direct sound dwFreeHwMixingStreamingBuffers = 0
direct sound dwMaxContigFreeHwMemBytes = 0
direct sound dwMaxHw3DAllBuffers = 0
direct sound dwMaxHw3DStaticBuffers = 0
direct sound dwMaxHw3DStreamingBuffers = 0
direct sound dwMaxHwMixingAllBuffers = 1
direct sound dwMaxHwMixingStaticBuffers = 1
direct sound dwMaxHwMixingStreamingBuffers = 1
direct sound dwMaxSecondarySampleRate = 200000
direct sound dwMinSecondarySampleRate = 100
direct sound dwPlayCpuOverheadSwBuffers = 0
direct sound dwPrimaryBuffers = 1
direct sound dwSize = 96
direct sound dwTotalHwMemBytes = 0
direct sound dwUnlockTransferRateHwBuffers = 0
setting the direct sound cooperative level
initializing oni persistance
initializing scripting
initializing binary data system
initializing imaging
initializing image system...
initializing motoko
initializing 3D display system..
initializing geometry engines...
initializing draw engines...
res.txt not found, loading default resoultions in 32-bit mode...
24 modes available
initializing physics
initializing oni motoko
initializing local input
initializing input system...
initializing animation system
initializing animation system...
initializing environment
initializing text system
initializing the console
initializing the materials
initializing the full sound system 2
initializing full sound system 2...
initializing particle 3
initializing oni particle 3
initializing env particle system
initializing physics
initializing game state
initializing AI 2
initializing window manager
initializing film system
initializing level
initializing oni scripting
initializing OBDr
initializing OBJr
initializing oni cinematics
initializing oni sound
initializing oni movie
initializing the pause screen
finished oni initializing
loading level 0...

any ideas about fixes?
p.s. don't have any stuff in my F drive because it's a cd-drive

Last edited by 6opoDuJIo (24/3/13 2:42)


Implement Oni with Unity3D engine :
https://github.com/6opoDuJIo/Oni-Round2

Offline

#2 24/3/13 10:29

Iritscen
Moderator

Re: AE, WIN8, Fault - any ideas?

Yeah, the F: drive is a reference to the original location of the source code when the app was built.  Can you post the AE Installer's log, Edition/install/install.log?  It looks like something went wrong during the installation process.


byproducts are fine, but where's the beef?

Offline

#3 24/3/13 19:56

6opoDuJIo
Member

Re: AE, WIN8, Fault - any ideas?

here it is:

[== Undefined ==]
Mod Installation started 2013-Mar-24 09:42:55
Reading files from C:\Users\6opoDuJIo\Downloads\Edition-PC-2010-05-Updated\Edition\install\VanillaDats\level0_Final;C:\Users\6opoDuJIo\Downloads\Edition-PC-2010-05-Updated\Edition\install\packages\Globalize\oni\level0_Final;C:\Users\6opoDuJIo\Downloads\Edition-PC-2010-05-Updated\Edition\install\packages\24000SeveredTextures\oni\level0_Final
Removing duplicates
Writing C:\Users\6opoDuJIo\Downloads\Edition-PC-2010-05-Updated\Edition\GameDataFolder\level0_Final.dat
Writing C:\Users\6opoDuJIo\Downloads\Edition-PC-2010-05-Updated\Edition\GameDataFolder\level0_Final.raw

Installation ended 2013-Mar-24 09:43:08
The process took 00:00:13

Implement Oni with Unity3D engine :
https://github.com/6opoDuJIo/Oni-Round2

Offline

#4 25/3/13 10:03

Iritscen
Moderator

Re: AE, WIN8, Fault - any ideas?

Urp.  You should place the Edition folder (that's inside Edition-PC-blahblah) inside the Oni installation on your HD.  smile  Then run the Installer in Edition/install/ again.


byproducts are fine, but where's the beef?

Offline

#5 25/3/13 11:20

6opoDuJIo
Member

Re: AE, WIN8, Fault - any ideas?

Iritscen wrote:

Urp.  You should place the Edition folder (that's inside Edition-PC-blahblah) inside the Oni installation on your HD.  smile  Then run the Installer in Edition/install/ again.

Sholdn't reglobalization just move all ONI content to local folder?


Implement Oni with Unity3D engine :
https://github.com/6opoDuJIo/Oni-Round2

Offline

#6 25/3/13 14:03

Iritscen
Moderator

Re: AE, WIN8, Fault - any ideas?

It will copy Oni's game data to the Edition/ folder, yes, but the AE Installer requires the Edition/ folder to be inside Oni/ before it can find the data it needs.


byproducts are fine, but where's the beef?

Offline

#7 25/3/13 22:52

6opoDuJIo
Member

Re: AE, WIN8, Fault - any ideas?

Ok, ty, now it works fine.


Implement Oni with Unity3D engine :
https://github.com/6opoDuJIo/Oni-Round2

Offline

#8 26/3/13 5:57

Iritscen
Moderator

Re: AE, WIN8, Fault - any ideas?

Glad to hear it.


byproducts are fine, but where's the beef?

Offline

Board footer

Powered by FluxBB