Oni Central Forum

A forum for the Oni community

You are not logged in.

#1 26/6/20 18:31

drybomber5
Member
Registered: 1/5/20

Oni (AE) won't start up in full screen.

Ok so the last time  this happened I had to do a system restore but I'm sure there's a simpler solution. When I start up oni ae, it gives you the option to play oni in full screen or "windowed" mode. Well I accidently clicked windowed mode and now every time I start up oni ae, even when I click "run oni in full screen" it still opens up in windowed mode.

Has anyone else had this issue?

Offline

#2 26/6/20 21:04

Samer
Member
From: Lebanon
Registered: 4/9/09
Website

Re: Oni (AE) won't start up in full screen.

Hi there.
Try setting the game resolution to match your screen resolution.


Join our Oni Facebook Group
Check My YouTube Channel for my Oni Videos.
Check My Wiki page for all my stuff

Offline

#3 27/6/20 13:57

drybomber5
Member
Registered: 1/5/20

Re: Oni (AE) won't start up in full screen.

Samer wrote:

Hi there.
Try setting the game resolution to match your screen resolution.

Tried that too, after trying so many, one of the resolutions (it was 3000 x something) made the whole screen go dark and now whether I open oni ae in window or full screen, it just appears black hmm.

Offline

#4 27/6/20 14:10

Iritscen
Moderator
From: NC, USA
Registered: 22/10/07

Re: Oni (AE) won't start up in full screen.

Try deleting the persist.dat in your AE folder.  It contains the resolution setting for Oni.  Be aware that this will wipe out your savegames, so you might want to back up the persist.dat first in case this doesn't help.  You could also copy the persist.dat from your main Oni/ folder to the Oni/AE/ folder if that has savegames in it.

If that doesn't help, try deleting daodan.ini in the AE folder, which contains settings for whether to run in full-screen or windowed mode.


Check out the Anniversary Edition Seven at ae.oni2.net!

Offline

#5 27/6/20 14:12

Delano762
Member
From: Poland
Registered: 29/12/10
Website

Re: Oni (AE) won't start up in full screen.

Sounds to me like a resolution limit issue.

First of all, are you using a 4K monitor? What's its resolution?

Second, try alt+enter to toggle between fullscreen and windowed, see what happens.

Also, try using Windows compatibility mode on the AE's Oni.exe to force the game to run at 640x480 and then see if the menu displays at all.

Last edited by Delano762 (27/6/20 14:12)


Circus Afro, Circus Afro, Polka Dot, Polka Dot!

Offline

#6 27/6/20 14:26

drybomber5
Member
Registered: 1/5/20

Re: Oni (AE) won't start up in full screen.

Iritscen wrote:

Try deleting the persist.dat in your AE folder.  It contains the resolution setting for Oni.  Be aware that this will wipe out your savegames, so you might want to back up the persist.dat first in case this doesn't help.  You could also copy the persist.dat from your main Oni/ folder to the Oni/AE/ folder if that has savegames in it.

If that doesn't help, try deleting daodan.ini in the AE folder, which contains settings for whether to run in full-screen or windowed mode.

This worked thank you so much!!!!! After deleting persist.dat it helped to bring the screen back from going blank but it was still not opening up in full screen. When I deleted daodan.ini, that's what did the trick. smile Much simpler solution than doing system restore.

Delano762 I have a 15.6" 3840 x 2160 resolution monitor, it's an OLED display. I did try the compatibility mode, but nothing changed.

Thanks everyone who responded!

Offline

#7 27/6/20 21:08

Iritscen
Moderator
From: NC, USA
Registered: 22/10/07

Re: Oni (AE) won't start up in full screen.

Cool, glad it worked for you :-)  It could have also worked if we got into editing the daodan.ini, but deleting it seemed like a quicker approach.  If it gets messed up again, see https://wiki.oni2.net/Daodan_DLL#All_Co … n_Settings and it may help.


Check out the Anniversary Edition Seven at ae.oni2.net!

Offline

Board footer

Powered by FluxBB