Oni Central Forum

A forum for the Oni community

You are not logged in.

#1 27/6/18 18:28

souvlaki
Member
From: Saint Petersburg, Russia
Registered: 19/4/17

Cannot install AE on macOS because of Java version mismatch

Greetings

The AE installer from http://mods.oni2.net/node/75 fails to run after specifying Oni installation folder.

6b3f6b39cdef9b06adfece702c95847b.png

macOS 10.13.4, Java 10.0.1, Mono 5.12.0.226_1 (Homebrew)

Java control panel screenshot (executed from system preferences):
2bb8b9a6e6ead55c2d028cb79504d303.png

Thanks beforehand

Last edited by souvlaki (27/6/18 18:28)

Offline

#2 27/6/18 21:45

Iritscen
Moderator
From: NC, USA
Registered: 22/10/07

Re: Cannot install AE on macOS because of Java version mismatch

Hmm, this is interesting... I had no idea there was a Java 10.  Going to java.com still offers you Java 8, which internally is v1.8 (meeting the minimum requirement of the AEI).  I see that Oracle is offering a Java Runtime v10 on their main web site, however.  It looks like the version number being presented internally, 10.0, now matches the public-facing version number.  I'll look into what causes the confusion in the AEI when it encounters "10.0".  The fix for now would be to downgrade to Java 8, if that's not an inconvenience.


byproducts are fine, but where's the beef?

Offline

#3 28/6/18 9:39

souvlaki
Member
From: Saint Petersburg, Russia
Registered: 19/4/17

Re: Cannot install AE on macOS because of Java version mismatch

Not really a fan of downgrading. Looks like I'll be waiting for an installer fix, even if it is not to appear soon.

Thanks!

Offline

Board footer

Powered by FluxBB