Oni Central Forum

A forum for the Oni community

You are not logged in.

#1 8/9/17 3:28

bayliss
Member
Registered: 8/9/17

daodan.ini is not saving

Attempting to play Oni using the Daodan DLL
Installation is successful, and I've confirmed this by checking the version within the game.

Problem is I can't change any settings using daodan.ini
When I launch the game after changing the .ini's contents, the file is set back to the way it was before, every single time.
I tried setting the file to read-only after making my changes and then launching the game, and that did prevent the file from going back, but I also confirmed that the changes I made were having no effect as they should.

I read the bit on the page I linked about using daodan.ini found in "...AppData\Local\VirtualStore\[install path]"
I never found any such file or directory like it says I should. My virtualstore directory is just empty. I tried manually creating the directory and copying daodan.ini there myself, same story there, the file has no effect on the game. I was launching the game as administrator before anyway, but I tried this just in case.

Don't want to use the Anniversary Edition, though I imagine it would just be installing the latest version of daodan dll anyway yeah?

Anyway, any help would be appreciated. Thank you for reading!

Offline

#2 8/9/17 8:13

Iritscen
Moderator
From: NC, USA
Registered: 22/10/07

Re: daodan.ini is not saving

Hmm, this is tricky for me to help with since I'm on a Mac and don't have time to launch a Windows VM right now, but I actually thought the .ini file went next to Oni and the Daodan DLL.  I know that page says it goes in VirtualStore\, but have you tried putting it next to Oni?  Where are you putting it when it gets reverted after you change it?  Apparently that at least tells you what path the Daodan is using for the file.

As far as the file being reverted, perhaps a change you made was interpreted by the Daodan as a corrupted .ini and it decided to start over with a fresh one.  Can you post the contents that you attempted to save in the .ini?


byproducts are fine, but where's the beef?

Offline

#3 8/9/17 8:55

s10k
Member
From: Portugal
Registered: 14/1/07
Website

Re: daodan.ini is not saving

Wild guess, maybe you are running into permission issues.

Is your oni directory on "x:\Program Files (x86)" folder? Maybe the program isn't being able to write to ini file next to the executable. If so you could probably move your Oni folder to x:\Games\Oni or another directory in your disk and see if the problem remains. Note that the daodan.ini file should be in the same directory of Oni.exe.

Offline

#4 8/9/17 9:03

Iritscen
Moderator
From: NC, USA
Registered: 22/10/07

Re: daodan.ini is not saving

s10k wrote:

Note that the daodan.ini file should be in the same directory of Oni.exe.

Do we need to adjust this part of the Daodan DLL article, then?  http://wiki.oni2.net/Daodan_DLL#Configuration


byproducts are fine, but where's the beef?

Offline

#5 8/9/17 11:25

s10k
Member
From: Portugal
Registered: 14/1/07
Website

Re: daodan.ini is not saving

I don't think so. It already mentions:
"This is the location where Daodan.ini must be placed if Oni is to be run as a non-administrator."
which is my case.

In fact the suggestion location and configuration that I gave is the same as mine. I think it is better than the default "x:\Program Files (x86)" nowadays because it maintains the original structure of files and the game can be run safely without admin rights.

In more recent windows versions if a program is installed on "x:\Program Files (x86)" you may run on the administrator permission issues, especially one like Oni which tries to save files to the same directory.

Last edited by s10k (8/9/17 11:25)

Offline

#6 8/9/17 17:11

bayliss
Member
Registered: 8/9/17

Re: daodan.ini is not saving

Thanks for the replies. I should have been more descriptive, so to answer your questions:

I did try manually copying the .ini into the virtualstore directory, but the very first thing I did is what you mentioned - having daodan.ini in the same directory as Oni.exe
The one in virtualstore didn't have its changes reverted upon launching the game (but still had no effect on the game), the one in the Oni.exe directory did. So it's clear that's the one that's being affected at least.
Also, I installed Oni in a different location from default, a folder for my games on a different hard drive.
I also uninstalled and tried installing to C:\Program Files (x86) and it was the same either way.

The changes I tried to make were stuff listed on the wiki which I just copy/pasted to make sure I wasn't typing anything wrong.
So like
alttab false
under the [windows] section

I also just tried a commented out line
#test
with nothing else in the .ini (except for the sections there by default) and it erased that too.

Last edited by bayliss (8/9/17 17:12)

Offline

#7 8/9/17 18:32

Iritscen
Moderator
From: NC, USA
Registered: 22/10/07

Re: daodan.ini is not saving

I'm not sure if the .ini supports comments or what the comment syntax is, but for the lines that change settings, you're supposed to follow the model on the wiki page:

[Devmode]
highres_console = True
showtriggervolumes = True

[gameplay]
CooldownTimer = False

Your example didn't use an equals sign, so I just want to make sure you're aware that it's needed.


byproducts are fine, but where's the beef?

Offline

#8 8/9/17 22:05

bayliss
Member
Registered: 8/9/17

Re: daodan.ini is not saving

Holy moly, I'm an idiot.
That was the exact problem. I'm so sorry I had you all read all that just because of a simple mistake.
Thanks so much for the help!

Offline

#9 8/9/17 22:26

Iritscen
Moderator
From: NC, USA
Registered: 22/10/07

Re: daodan.ini is not saving

Heh, no problem.  It only took a few of our minutes.  Glad that it's working for you now!


byproducts are fine, but where's the beef?

Offline

Board footer

Powered by FluxBB