Oni Central Forum

A forum for the Oni community

You are not logged in.

#1 1/3/15 11:10

Barnak
Member

Trouble with using AE on Mac OS X

Hi all !  I'm new here.

I have the old Oni game from the CD and it's working great on my Mac mini 2009 (OS X Snow Leopard), using the latest Oni app (2011 ?).

I have Mono installed, and when I launch the AE app, it asks for my Oni folder.  Right, but then I get this error message :

sh: /Library/internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java
no such file or directory.

I installed the latest java for OSX Snow Leopard.

Now I don't know what to do.

Apparently, there's some java file missing that AE is asking.  Could some gentle soul send it to me by email ?

I also tried to install several HD textures modifications for Oni (from Oni Mod Depot), but I'm unable to convert the .oni files to the proper format, using the OniSplit app (I'm unable to make it to work).  Why is it so complicated ?

I need help in setting an HD version of Oni.

Last edited by Barnak (1/3/15 11:12)

Offline

#2 1/3/15 12:33

Iritscen
Moderator

Re: Trouble with using AE on Mac OS X

Ah, okay, this might be my fault for not testing the latest Setup app in 10.6.  I assume you're using Snow Leopard for backwards compatibility reasons?  Otherwise I recommend upgrading to 10.9.  The problem with Java is that the manner in which it comes pre-installed is probably different in 10.6.  I won't be able to do any tests until later today, but one thing you can try is installing this version of Java, which looks like it will place Java in the proper location on your hard drive.

Sorry if you've been misled by some instructions somewhere on installing mods, but you don't need to do any personal conversions of any files when you use the AE.  Once the AE is installed, the AE Installer will show you any mod packages that are offered on the Mod Depot (most mods are in this format now), and installing them simply requires checking their boxes and hitting Install.


byproducts are fine, but where's the beef?

Offline

#3 1/3/15 12:53

Barnak
Member

Re: Trouble with using AE on Mac OS X

I already installed the latest version of java for OS X 10.6.

AE is getting me the error message given above.

Do you have a file inside that path, which I could try ?  I do have a Contents folder, but no Home/bin/java.

Offline

#4 1/3/15 13:03

Barnak
Member

Re: Trouble with using AE on Mac OS X

Take note that I can't downgrade java (I tried).

I suspect that just adding that absent Home/bin/java file inside my JavaAppletPlugin.plugin/Contents folder could do the trick.

Do you have a "Home/bin/java" file in that java plugin ?

Offline

#5 1/3/15 15:57

Barnak
Member

Re: Trouble with using AE on Mac OS X

Iritscen,

I solved a part of my problem with the AE pre-installer.  In the main.scpt file, I changed that line of code :

set javaPathJRE to "/Library/Internet\\ Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java"

to this (I'm not a script expert.  I got help from a friend) :

set javaPathJRE to "/usr/bin/java"

I then ran the installer and it worked.  I got a new AE folder with just a few files inside :

- Run AE Installer (script file)
- AEInstaller/AEInstaller2Updater.jar

I ran the Run AE Installer, and after a few sec, I got no message at all and the script quitted.  Now what ?
How do I install new ressources from this ?  This is a total mystery to me.

What should I do with the AEInstaller/AEInstaller2Updater.jar file ?  I decompressed it, and got more mysterious folders and files (no app).

For example, I downloaded that 26000Konoko_HD_Armor folder which adds a high res of Konoko's armor.  How do I install it ?



EDIT :  I now suspect that the "Run AE Installer" script isn't properly working.
I guess that the script code need to be edited in some similar way of what I've done for the pre-installer, but things look more complicated now.

Last edited by Barnak (1/3/15 16:30)

Offline

#6 1/3/15 18:25

Iritscen
Moderator

Re: Trouble with using AE on Mac OS X

Well, the answer to this problem is not to give you files from another version of the OS.  They probably won't even work.  I need to update the Setup app to work with it properly.  I recently changed AE Setup in a way that I thought was an improvement, but now I see that I accidentally dropped 10.6 support.  I can see in a 10.6 installation of mine that the Java files are indeed distributed differently, so I'm working on a solution now.


byproducts are fine, but where's the beef?

Offline

#7 1/3/15 18:27

Iritscen
Moderator

Re: Trouble with using AE on Mac OS X

Okay, the last post was written before your last reply.  In answer to that, yes, you did fix the AE Setup script for your computer, and the same change would need to be made to the Run AE Installer script.  They are both trying to access Java in what is the wrong location on 10.6.  For you, it should indeed be /usr/bin/java.


byproducts are fine, but where's the beef?

Offline

#8 1/3/15 19:38

Barnak
Member

Re: Trouble with using AE on Mac OS X

Yep, the installer is now working.  I have the full interface now.

Didn't tried Oni yet.

Offline

#9 1/3/15 21:14

Barnak
Member

Re: Trouble with using AE on Mac OS X

Cool !  Everything appears to be working.  The new textures and models are looking really great.

I get lags at some places, but that's probably because my old Mac mini 2009 (4GB ram) isn't fast enough for all the new stuff.
The game is still very playable anyway.

Offline

#10 2/3/15 9:42

Iritscen
Moderator

Re: Trouble with using AE on Mac OS X

Okay, when you say everything is working, do you mean the AE where you changed those two scripts?  Just an FYI, I sent an email with a new version of the Setup app that is supposed to work in 10.6, so please let me know if that can install the AE on your computer successfully.


byproducts are fine, but where's the beef?

Offline

#11 2/3/15 10:20

Barnak
Member

Re: Trouble with using AE on Mac OS X

Yes, the full AE installation is working, after I edited the scripts.

I tried Oni with 26 addons (mainly all the HD textures and HD models, new weapons...)

Everything works great so far.  I'll try more addons...

As stated before, the final version 1.1 is crashing if I toggle ON the -vsync option.  Not sure it's the cause, tough.

EDIT :  Ok, I received your email.  Scroll wheel crashing the game ?  I don't use the scroll button, but it's easy to touch by mistake (yep, I still use that old mouse from Apple.).

Last edited by Barnak (2/3/15 10:32)

Offline

#12 2/3/15 14:45

Iritscen
Moderator

Re: Trouble with using AE on Mac OS X

Yeah, if you can avoid the scroll wheel, please do so.  I don't know if Feral plans to release a new 1.1 build to fix this bug.  Hardly anyone is supporting 10.6 these days.

I was hoping you could test the new AE Setup I emailed you, because then I can upload it to the Depot for any future users who are in 10.6.  You just need to move the old AE/ folder out of the way so that Setup thinks you don't have the AE installed, and then see if the new Setup app can run the AE Installer Updater and launch the AE Installer.  If it gets that far, then it's working; no need to initialize the Edition when the AEI prompts you.  It worked in my test in an archived 10.6 installation I keep on-hand, but I was hoping for verification from one more user before I upload it.

Also, how did you run the current AE Setup app (v1.1.3) on your Mac?  Because it won't even launch for me in 10.6, telling me that "this type of Mac" does not support it.  It seems that AppleScript no longer produces 10.6-compatible applications when used from 10.10.  I had to use an earlier OS to make the 1.1.4 app that I sent you.


byproducts are fine, but where's the beef?

Offline

#13 2/3/15 15:08

Barnak
Member

Re: Trouble with using AE on Mac OS X

I tested the script you have sent to me.  It's working fine.  All the installation process worked.

AE Setup app 1.1.3 ?  I don't understand.  I just ran the script that your file created.  Everything appears to be working great.
I'm using the Mac style interface, and the file list is very clear.  Simple to understand and to use.

It's a great tool for that old game.

I was able to download and install up to 68 addons for Oni !  The game was getting extremely laggy in some levels.  Once I disactivated about half addons, all were back to normal (smooth).

Last edited by Barnak (2/3/15 15:09)

Offline

#14 2/3/15 16:40

Iritscen
Moderator

Re: Trouble with using AE on Mac OS X

Yeah, I definitely wouldn't install that many mods.  How do you even know what they are doing?

Anyway, thanks for testing the AE Setup app.  What I meant before is that the AE Setup I have been offering on the Depot doesn't seem to run in 10.6.  Maybe that's a problem specific to my archived 10.6 installation.


byproducts are fine, but where's the beef?

Offline

#15 2/3/15 16:54

Barnak
Member

Re: Trouble with using AE on Mac OS X

Iritscen wrote:

How do you even know what they are doing?

Most of them are High Res textures and models.  I installed also many new weapons (some are really pure madness, especially when you turn on some weapon cheats !).  Konoko's new armor is awesome.  Her new motorcycle is pretty cool too.

The broken glass addon is great, and the blood on floor/walls is, well, ... insane (maybe too violent in that kind of japan anime style game, I don't know).

I tried many new mission scripts, but wasn't able to trigger them yet.

Last edited by Barnak (2/3/15 16:57)

Offline

#16 2/3/15 18:04

Iritscen
Moderator

Re: Trouble with using AE on Mac OS X

Yes, I'm a fan of the new Konoko armor model too.  If you need help getting into a new mission you installed, you might want to ask about it specifically in a new thread.


byproducts are fine, but where's the beef?

Offline

Board footer

Powered by FluxBB