Oni Central Forum

A forum for the Oni community

You are not logged in.

#1 31/10/14 4:13

Durero
Member
Registered: 31/10/14

Oni crashing on start on Mac OS X 10.10

Was working fine on OS X 10.9

Tried reinstalling today but no luck.

Anyone else having this problem?

Offline

#2 31/10/14 10:08

Iritscen
Moderator
From: NC, USA
Registered: 22/10/07

Re: Oni crashing on start on Mac OS X 10.10

Yes, unfortunately 10.10 does not support the last public release of Oni.  Feral is working on a new build of Oni which we're hoping will be released soon.


byproducts are fine, but where's the beef?

Offline

#3 31/10/14 23:29

Durero
Member
Registered: 31/10/14

Re: Oni crashing on start on Mac OS X 10.10

Thanks very much for your reply.

I hope a new build will appear smile

Offline

#4 9/11/14 10:33

SAHunterMech
Member
Registered: 9/11/14

Re: Oni crashing on start on Mac OS X 10.10

...I shouldn't have upgraded. This is the sole reason I should not have upgraded. I tried multiple things, including a fresh install of the AE (I've been updating my build since 2010 or so), but nothing will make the game launch.

Interestingly, now I can't get the actual AEI to launch on my mac either. This is the udpater_output.log file I have right now:

Error while getting information of working copy for the location 'http : //svn.aei.oni2.net': svn: E155007: '/Users/mech/Desktop/Games/Mac/Oni/AE/AEInstaller/bin' is not a working copy
java.lang.Exception: Destination path exists but is not a Working Copy of the SVN
	at net.oni2.svnaccess.SVN.checkSVN(SVN.java:115)
	at net.oni2.aeinstaller.updater.gui.MainWin$Updater.doInBackground(MainWin.java:136)
	at net.oni2.aeinstaller.updater.gui.MainWin$Updater.doInBackground(MainWin.java:1)
	at javax.swing.SwingWorker$1.call(SwingWorker.java:295)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at javax.swing.SwingWorker.run(SwingWorker.java:334)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)

Could this potentially be a problem for users trying to do a fresh install on Yosemite?

Offline

#5 9/11/14 11:37

Iritscen
Moderator
From: NC, USA
Registered: 22/10/07

Re: Oni crashing on start on Mac OS X 10.10

Hmm, the AE error is strange.  A fresh install of the AE in Yosemite worked for me.  Can you try deleting the bin/ folder in AEInstaller/, and then open the "Run AE Installer" shortcut?  This should reinstall the Installer.  Somehow its files seem to have been corrupted.

Coming back to the subject of Oni for 10.10, I'm not aware of any way to fix the existing game so it doesn't crash.  If anyone wants to, they can email Feral at support@feralinteractive.com asking when the new build will be released, although I'm not sure if the person at the main support email address will be familiar with the situation.  Maintaining the Oni application is not so much an obligation of Feral's as it is an unofficial side project.  The official forum thread for the build is here; maybe bumping it will alert edddeduck if he's subscribed to it: http://oni.bungie.org/forum/viewtopic.php?id=848


byproducts are fine, but where's the beef?

Offline

#6 9/11/14 13:24

SAHunterMech
Member
Registered: 9/11/14

Re: Oni crashing on start on Mac OS X 10.10

I forgot to mention one other thing... the first time I run the AE Updater, the app will just sit there and do nothing. It doesn't freeze, doesn't give me the spinny wheel of death, but it never starts updating. Anyway, I'll try your solution; at the very least, it would be nice to have my mods good to go for when Oni is ready for Yosemite.

EDIT: Okay, the phones. Hold them. My bin folder is empty already. Durr. This is DEFINITELY not installing correctly.

Last edited by SAHunterMech (9/11/14 13:29)

Offline

#7 9/11/14 14:33

Iritscen
Moderator
From: NC, USA
Registered: 22/10/07

Re: Oni crashing on start on Mac OS X 10.10

You're not using a proxy for Internet access by any chance, are you?  Because it sounds like there's a total failure of the AE Updater to connect to our site.

Just so I'm clear, did you delete the bin/ folder and run the Updater again?  We'd be interested in seeing the contents of updater_output.log after you run Updater for the first time, that is, with no bin/ folder present beforehand.  In other words, the error message it prints could be different on that first run than on the subsequent times you run it with a bin/ folder.


byproducts are fine, but where's the beef?

Offline

#8 9/11/14 21:20

SAHunterMech
Member
Registered: 9/11/14

Re: Oni crashing on start on Mac OS X 10.10

I use a proxy, but it's an app in my browser (chrome). Every time I run the updater for the first time, on a clean install, it hangs and never puts anything in the bin folder; Doesn't give me the spinning wheel of death though. It definitely seems like the connection is timing out or something... Yosemite has a lot of issues with Wifi, and I wouldn't be surprised if they had something to do with the fact that the app can't connect. I mean, hell, I just got my wifi working on my mac a few days ago, after almost 2 weeks without it.

THIS is what the updater_output.log says on a first-time AE install. Keep in mind, the installer hangs, so this log was written DURING said hanging.

Error while getting the list of files of the location 'http : //svn.aei.oni2.net': svn: E175002: Processing PROPFIND request response failed: Premature end of file. (/)
svn: E175002: PROPFIND request failed on '/'

Last edited by SAHunterMech (9/11/14 21:21)

Offline

#9 10/11/14 10:42

Iritscen
Moderator
From: NC, USA
Registered: 22/10/07

Re: Oni crashing on start on Mac OS X 10.10

Hmm, can you use the Internet with a wired connection instead then?  All we can tell so far is that it does seem like a connection problem.


byproducts are fine, but where's the beef?

Offline

#10 10/11/14 11:13

SAHunterMech
Member
Registered: 9/11/14

Re: Oni crashing on start on Mac OS X 10.10

yeah, agreed, I just have no idea if it's Yosemite or just my internet. Anyway, I can try a wired connection. If it's any consolation, I just ran the installer on another computer of mine (Running Lion), dragged the files onto my computer, and it works fine. Well, except for the whole 'Oni doesn't run on Yosemite' thing, but what's extra weird is that I can install mods just fine on my Yosemite computer.

Offline

#11 10/11/14 13:11

Iritscen
Moderator
From: NC, USA
Registered: 22/10/07

Re: Oni crashing on start on Mac OS X 10.10

Yes, well the mod installation process runs on Java and C# (through Mono) as well as some natively-compiled C, so as long as there's support in Java and Mono for the latest version of OS X, the AE should always work, even if Oni doesn't.


byproducts are fine, but where's the beef?

Offline

#12 10/11/14 22:53

SAHunterMech
Member
Registered: 9/11/14

Re: Oni crashing on start on Mac OS X 10.10

Granted, it's just curious how the app will connect to the Oni Mod depot and install mods just fine, but it won't connect during an update.

Offline

#13 11/11/14 10:02

Iritscen
Moderator
From: NC, USA
Registered: 22/10/07

Re: Oni crashing on start on Mac OS X 10.10

Oh, I see what you mean.  Well, the process of downloading/updating the AEI works through Subversion, which is a complex program that seems to be a bit touchy when it comes to bad connections, but the mod download/update process is a simple FTP transfer (or maybe HTTP?).

I'm still interested to know if a wired connection works better for you.  In the meantime, it seems that Apple is working on a fix for the wi-fi issue.


byproducts are fine, but where's the beef?

Offline

#14 18/11/14 11:20

SAHunterMech
Member
Registered: 9/11/14

Re: Oni crashing on start on Mac OS X 10.10

Well, I tried an Ethernet connection (which has to go through Thunderbolt via an adaptor, thanks for making me spend more money, Apple), and it still hangs. Just to clarify, I did manage to get my internet sorted out by signing myself up for the OS X 10.10.1 beta.

Also, I'm doing another playthrough on my older Mac; it's been TOO long. I don't mean to sound like a lamewad, but I... kind of like to play mod-free. I liked the Andashi Melee system, but I can't seem to find that mod anymore.

Offline

#15 18/11/14 14:11

Iritscen
Moderator
From: NC, USA
Registered: 22/10/07

Re: Oni crashing on start on Mac OS X 10.10

Oof, I forgot all about that mod, even though it's quite significant.  It seems that last time we discussed it, it was a huge project, because we can't just bring over the old files if we're going to do this properly.  We were going to analyze it and some related mods, and figure out what changes to bring over.  It may have also needed to be made into an XML mod.  At the time we discussed it, XML modding was still a work in progress, so I think we lost track of the Andrashi mod, and I moved on to other projects after finishing some other XML modding work.

I have to think about what we should do here.  In the meantime, it would be possible for a player to "port" the mod from the 2009/2010 AE to AE 7 with little difficulty.  It might even work as-is, if dragged into the AEInstaller/packages/ folder and installed with the AE Installer.  It may just clobber some other mods, but if you don't have any others installed, it shouldn't matter.  The old package can be downloaded by clicking this: http://websvn.chrilly.net/dl.php?repnam … 9&peg=1009


byproducts are fine, but where's the beef?

Offline

#16 2/12/14 19:42

SAHunterMech
Member
Registered: 9/11/14

Re: Oni crashing on start on Mac OS X 10.10

Hey, uh, it worked. Yay...?

Offline

#17 2/12/14 22:15

Iritscen
Moderator
From: NC, USA
Registered: 22/10/07

Re: Oni crashing on start on Mac OS X 10.10

Okay, that's good. In order to give it a proper release, we still need to take the time to look over that old mod and break down its changes into categories, and I think its fixes need to be merged with love_Oni's Fixed Moves and similar TRAM fixes.

On the subject of the OP, I've been told that Feral is aiming to put out the 10.10-compatible Oni build this month, so hang in there guys.


byproducts are fine, but where's the beef?

Offline

#18 3/12/14 14:25

Dirk Gently
Member
From: Boston, MA
Registered: 12/6/09
Website

Re: Oni crashing on start on Mac OS X 10.10

Thanks for the good news!

Offline

#19 3/2/15 16:22

Zapranoth
Member
Registered: 3/2/15

Re: Oni crashing on start on Mac OS X 10.10

Any update on this?  I'm trying to run the game on the current 10.10 build and I'm getting the crash on loading.   

(I have installed Mono, and then the AE installer with no mods, but I can't get the app to run at all)

And thank you!  smile

Last edited by Zapranoth (3/2/15 17:34)

Offline

#20 3/2/15 19:12

Iritscen
Moderator
From: NC, USA
Registered: 22/10/07

Re: Oni crashing on start on Mac OS X 10.10

Hi there.  The new Oni build for 10.10 hasn't officially been released by Feral, but if you look at this post, you'll see a link for a test build of Oni 1.2 which works in 10.10.


byproducts are fine, but where's the beef?

Offline

#21 3/2/15 20:07

Zapranoth
Member
Registered: 3/2/15

Re: Oni crashing on start on Mac OS X 10.10

You, sir, are entirely too kind.  It works!  Whoa!  smile  Thank you!

Offline

#22 3/2/15 22:56

Iritscen
Moderator
From: NC, USA
Registered: 22/10/07

Re: Oni crashing on start on Mac OS X 10.10

No problem, glad to hear it's working for you.


byproducts are fine, but where's the beef?

Offline

Board footer

Powered by FluxBB