Oni Central Forum

A forum for the Oni community

You are not logged in.

#1 31/12/14 12:32

Vadell Gabriel
Member
From: Halifax, Nova Scotia, NS
Registered: 19/3/14

Oni is refusing to go into full-screen mode

Not long after I fixed my first problem, I restarted the AE, and booted Oni again. However when I hit the "run full-screen" button, it goes into windowed mode instead of full-screen. Is there any reason this would happen?

Offline

#2 31/12/14 14:00

Iritscen
Moderator
From: NC, USA
Registered: 22/10/07

Re: Oni is refusing to go into full-screen mode

It sounds like maybe the Daodan's settings are calling for windowed mode and overriding the launch argument which the AE Installer is passing Oni.  Look in daodan.ini for a reference to "switch" or "noswitch".


byproducts are fine, but where's the beef?

Offline

#3 31/12/14 14:40

Vadell Gabriel
Member
From: Halifax, Nova Scotia, NS
Registered: 19/3/14

Re: Oni is refusing to go into full-screen mode

This is all I got from the Dadoan:

[devmode]

[gameplay]

[graphics]

[language]

[modding]

[oni]
debugfiles = true

[windows]

Offline

#4 31/12/14 16:57

Iritscen
Moderator
From: NC, USA
Registered: 22/10/07

Re: Oni is refusing to go into full-screen mode

Okay, that's strange, then.  Maybe a Windows user can be of more help to you.  But if you are comfortable with the command line, you can try calling Oni with "Oni.exe -switch".  I think the Daodan DLL added that as a launch argument for running in full-screen mode.


byproducts are fine, but where's the beef?

Offline

#5 31/12/14 18:14

Vadell Gabriel
Member
From: Halifax, Nova Scotia, NS
Registered: 19/3/14

Re: Oni is refusing to go into full-screen mode

I actually managed to fix it. I forced it to boot to fullscreen by using the "Run_full" batch file. Now the AE boots the fullscreen mode normally.

Offline

#6 31/12/14 18:46

Iritscen
Moderator
From: NC, USA
Registered: 22/10/07

Re: Oni is refusing to go into full-screen mode

Hmm, interesting.


byproducts are fine, but where's the beef?

Offline

#7 1/1/15 21:28

Gumby
Member
From: Seattle, WA, USA
Registered: 30/8/07

Re: Oni is refusing to go into full-screen mode

Um, one of the video modes is broken.


Iritscen: roll
Iritscen: it's amazing this program even works
Gumby: i know
Iritscen: and that statement applies to my code, not just yours

Offline

#8 1/1/15 21:29

Gumby
Member
From: Seattle, WA, USA
Registered: 30/8/07

Re: Oni is refusing to go into full-screen mode

Try

[Patch]
windowhack = true
usedaodangl = false

We really should recompile the daodan with those options toggled.


Iritscen: roll
Iritscen: it's amazing this program even works
Gumby: i know
Iritscen: and that statement applies to my code, not just yours

Offline

Board footer

Powered by FluxBB