Oni Central Forum

A forum for the Oni community

You are not logged in.

#1 16/6/07 10:23

KenzieK
Member
Registered: 16/6/07

Lagging like mad :mad:

Hi, I'm trying to start playing Oni again because I miss the great gameplay that i had back when I was 12(ish...I think). I installe Oni with out any problems, when I open Oni and get to the Main Menu my courser starts to lagg and i have no idea why. I meet the system requierments if not pass them, my system properties are:

Microsoft Windows XP Pro./ Version 2002/ SP 2
AMD Althlon XP 2500 + 1.85GHz
512MB Ram
and the rest is a blurr

         Thanks for any help given big_smile

Offline

#2 16/6/07 12:38

geyser
Member
From: beyond the veil
Registered: 14/1/07
Website

Re: Lagging like mad :mad:

Information on your GFX (graphics) card and driver would be helpful.
An easy way to get some is to download and run this: http://sfeli.oni2.net/files/glist.zip
Unpack and run glist.exe, then post the output here.

Oni also prints some information about your GFX card to startup.txt
Just look up that file in your Oni folder and post its contents here.


Behold the power of that which is yet unborn! For the swirling images that flow forth from the Chrysalis are only a shadow of the sleeper's true power.

Offline

#3 18/6/07 4:55

sizor
Member
Registered: 18/6/07

Re: Lagging like mad :mad:

sssvl5.png
here smile
when i run oni on my compeuter the CPU is going crazy, like 90%+. maybe it have any conection with the fact im laging. and i did tryed the win98 mod.

Offline

#4 18/6/07 16:52

Ether
Member
From: Czech Republic
Registered: 26/5/07

Re: Lagging like mad :mad:

I think that the problem is very much simple - you're probably using software rendering. What graphics card do you have? Go to the Device Manager (Start-Run-"devmgmt.msc") and tell us what exactly is in the Graphic Adapters (or like that) section.

BTW the fact that your CPU usage is 90%+ has certainly something to do with the lagging.

Last edited by Ether (18/6/07 16:53)

Offline

#5 18/6/07 17:40

geyser
Member
From: beyond the veil
Registered: 14/1/07
Website

Re: Lagging like mad :mad:

The CPU usage in terms of idle cycles is always around 100% here whenever Oni is running...
The Task Manager doesn't really allow one to evaluate the actual CPU usage because of that.

As for software/generic rendering: yes, that's indicated by the "GENERIC_FORMAT = yes" tag.
Also note "Driver vendor: Microsoft Corporation" and "Renderer: GDI Generic"... Questions? wink

According to SFeLi (who recommended the "glist" diagnosis above), the picture is as follows:

SFeLi wrote:

If the vendor is Microsoft — it's bad, and if on top of that the renderer is GDI — it's even worse. As for the flags: if both are down — OpenGL is handled by the GFX hardware driver; if ACCELERATED is set along with GENERIC_FORMAT — as far as I can tell, OpenGL is accelerated by the driver or the GFX hardware on top of GDI (that's a slowdown already); if GENERIC_FORMAT is the only one set — you can go hang yourself (but it's better to try and install a driver for your GFX card ;-) ); and as for ACCELERATED, it apparently can't be set on its own.
So if you get a "slideshow" with both flags down — the matter is NOT with the GFX card/driver, and if the vendor is Microsoft — you 100% should get a driver from the GFX card manufacturer (when you first install XP, for instance, an NVIDIA card gets MS's default drivers, without hardware acceleration).
Oh, and if the extensions list is over 2028 bytes (give or take a few), there's a guaranteed Blam at startup on a non-patched standard version (buffer overflow).

Translated from Russian by me. I could add that if both flags are OFF, then there might be a driver issue (you may have GFX-specific drivers, but they may be outdated or otherwise unappropriate).

In more detail:

0) "Driver vendor: Microsoft Corporation" means your (possibly kick-ass) GFX card is ignored and one of MS's lousy default drivers is used instead of a GFX-card-specific one. Get a driver from your card's manufacturer.

0 bis) "Renderer: GDI Generic" means that not only you are using a lousy default driver by MS, but you are using the lousiest MS has. Basically, Windows can't tell whether your GFX card is an ATI or an Nvidia or a Hercules or whatever, so it assumes it is a bread toaster.

0 ter) If any of the above applies, it's in your interest to find and install a proper driver for your GFX card (unless it really is a bread toaster; one with no indentifiable manufacturer, or one that doesn't support OpenGL or 3D acceleration at all).

1) if "GENERIC_FORMAT = no" and "GENERIC_ACCELERATED = no", OpenGL is handled by your GFX card (hardware). You still may have have problems with an outdated/unappropriate driver, but at least your GFX card does take the OpenGL load off the generic renderer.

1 bis) If "GENERIC_FORMAT = yes" (possibly with "GENERIC_ACCELERATED = yes" as well), you also should try and get a specific driver for your GFX card (typically, the renderer is "GDI Generic" in those cases: see (0 bis) to know how bad that is)

2) If you're experiencing lag, the startup Blam is probably not a problem for you. If it is, it's a completely different story anyway smile

Last edited by geyser (19/6/07 21:03)


Behold the power of that which is yet unborn! For the swirling images that flow forth from the Chrysalis are only a shadow of the sleeper's true power.

Offline

#6 19/6/07 18:05

sizor
Member
Registered: 18/6/07

Re: Lagging like mad :mad:

3dfx vodoo 4.
the game worked when i had win98. since i switched xp and put 2.4gh celeron and 256mb memory the game doesnt working.
I had the same GFX in win98 and winXP.
my AGP texture acceleration is disable, duno why.
thanks for your help! you are really nice and considering.

Offline

#7 19/6/07 19:03

geyser
Member
From: beyond the veil
Registered: 14/1/07
Website

Re: Lagging like mad :mad:

and i did tryed the win98 mod.

OK, so the compatibility mode doesn't help...

i switched xp and put 2.4gh celeron and 256mb memory

Celeron usually sucks, but a 2.4 GHz one (really?) maybe doesn't.
256 MB of RAM is not much, though. XP will hog most of it... smile
That means your Oni might be using "virtual" RAM now.
(swapping things to HDD... guaranteed slowdown)

Last edited by geyser (19/6/07 20:41)


Behold the power of that which is yet unborn! For the swirling images that flow forth from the Chrysalis are only a shadow of the sleeper's true power.

Offline

#8 20/6/07 15:15

Ether
Member
From: Czech Republic
Registered: 26/5/07

Re: Lagging like mad :mad:

One way or another, try installing manufacturer's drivers from here: http://www.voodoofiles.com/category.asp?x=2 or from elsewhere.

Last edited by Ether (20/6/07 15:15)

Offline

#9 20/6/07 18:15

sizor
Member
Registered: 18/6/07

Re: Lagging like mad :mad:

I can work max fain, red faction and gta so i dont think the game is too strong for my compeuter.

download the LATEST driver from there and the AGP TEXTURE option is still disable.
and now when i enter ONI its writhing me- "blam, oni crash".

Offline

#10 20/6/07 19:12

geyser
Member
From: beyond the veil
Registered: 14/1/07
Website

Re: Lagging like mad :mad:

For some info on the Blam at startup, see here if you're curious: http://wiki.oni2.net/index.php/Blam
If you have an English version of Oni, you can use this: http://geyser.oni2.net/EXE/pc.east/
Copy both the EXE and the DLL into your Oni folder and play (backup your original EXE)

Last edited by geyser (21/6/07 10:34)


Behold the power of that which is yet unborn! For the swirling images that flow forth from the Chrysalis are only a shadow of the sleeper's true power.

Offline

#11 21/6/07 7:17

s10k
Member
From: Portugal
Registered: 14/1/07
Website

Re: Lagging like mad :mad:

sizor wrote:

I can work max fain, red faction and gta so i dont think the game is too strong for my compeuter.

download the LATEST driver from there and the AGP TEXTURE option is still disable.
and now when i enter ONI its writhing me- "blam, oni crash".

If the agp texture option still disable your card is being used by windows as pci. Update your motherboard drivers.
http://script10000.oni2.net/patches.html

Offline

#12 21/6/07 10:42

geyser
Member
From: beyond the veil
Registered: 14/1/07
Website

Re: Lagging like mad :mad:

The Voodoo 4 exists in a PCI version. You sure you have the AGP one, sizor?
It would be a bit ironic if the motherboard's driver didn't recognize its own AGP slot hmm
But it's always a good idea to update the drivers for your hardware now and then.


Behold the power of that which is yet unborn! For the swirling images that flow forth from the Chrysalis are only a shadow of the sleeper's true power.

Offline

#13 21/6/07 17:02

s10k
Member
From: Portugal
Registered: 14/1/07
Website

Re: Lagging like mad :mad:

geyser wrote:

The Voodoo 4 exists in a PCI version. You sure you have the AGP one, sizor?
It would be a bit ironic if the motherboard's driver didn't recognize its own AGP slot hmm
But it's always a good idea to update the drivers for your hardware now and then.

Well my windows xp and 2000 recognise also my geforce as pci, I need always update the driver of motherboard.

Offline

#14 23/6/07 16:47

sizor
Member
Registered: 18/6/07

Re: Lagging like mad :mad:

i instaled other driver and now oni is working but laging.

Offline

#15 23/6/07 18:15

geyser
Member
From: beyond the veil
Registered: 14/1/07
Website

Re: Lagging like mad :mad:

The newer drivers caused Oni to Blam at startup. We told you how to fix this.
You didn't tell us if you managed to fix the Blam. You should be able to fix it.
I'd say try again: if the EXE and Daodan DLL don't work for you, tell us so.


Behold the power of that which is yet unborn! For the swirling images that flow forth from the Chrysalis are only a shadow of the sleeper's true power.

Offline

Board footer

Powered by FluxBB