Oni Central Forum

A forum for the Oni community

You are not logged in.

#1 23/6/09 6:07

samanth0r
Member
Registered: 23/6/09

Mouse/Response Issues

I recently dug up Oni when I was thinking about playing it yesterday and remembered how much fun it was.
I had the inital teething difficulties , but managed to get Daodan installed (Latest non beta patch) and the game running in a window.
BUT i have been having a curious Mouse issue.

Much like the issue stated :

http://oni.bungie.org/community/forum/v … 1952#p1952
and
http://oni.bungie.org/community/forum/v … php?id=907

It's like my mouse (in both full screen and in a window) is moving on a grid both when aiming weapons and in general mouse movement, sometimes it becomes completely unresponsive to my commands entirely.

I'm running Vista 32bit updated to latest. Latest ATI drivers.
Core2Duo 3.16 4gb RAM, Radeon 4850 with 1gbvram. My system SHOULD run it fine.

I've played around with mouse sensitivity in the system controls putting on low and putting it on high makes no difference to the issue just changes how far the mouse 'skips' when i pan the in game camera.
If anybody has any clue on how to fix this please let me know.

Thanks, Samantha

Offline

#2 23/6/09 10:53

Gumby
Member
From: Seattle, WA, USA
Registered: 30/8/07

Re: Mouse/Response Issues

Indeed, your system should be running fine.

1. I know you say you have the latest drivers, and its nothing against you, but please update them again. Half of the time, someone says they are running the latest drivers, but they really aren't.
2. Try the beta patch. smile
3. Try closing all background programs (you really shouldn't need to, with 4 GB of RAM, but it won't hurt to try).


Iritscen: roll
Iritscen: it's amazing this program even works
Gumby: i know
Iritscen: and that statement applies to my code, not just yours

Offline

#3 24/6/09 11:48

Gumby
Member
From: Seattle, WA, USA
Registered: 30/8/07

Re: Mouse/Response Issues

Aha, forgot something we should probably try. It is possible that your system is running too fast. smile

1. Turn on anti aliasing in the Catalyst Control Panel (like 16x, to attempt to slow the frame rate, your card should handle it fine)
2. Turn on V-sync in your Catalyst Control Panel (to lock the frame rate to a multiple of 60, perfect for Oni)


Iritscen: roll
Iritscen: it's amazing this program even works
Gumby: i know
Iritscen: and that statement applies to my code, not just yours

Offline

#4 25/6/09 0:30

RaHarakni
Member
Registered: 4/5/09

Re: Mouse/Response Issues

Hey there just thought I'd tell you I tried turning on v-sync in catalyst and it solved the control issues I was having some time back. Can't believe I didn't think to turn it on earlier! I bet it will probably work for anyone else having similar problems. Thanks a bunch!

Offline

#5 25/6/09 1:03

Gumby
Member
From: Seattle, WA, USA
Registered: 30/8/07

Re: Mouse/Response Issues

Success!


Iritscen: roll
Iritscen: it's amazing this program even works
Gumby: i know
Iritscen: and that statement applies to my code, not just yours

Offline

#6 25/6/09 9:35

Iritscen
Moderator
From: NC, USA
Registered: 22/10/07

Re: Mouse/Response Issues

But what about samanth0r?


byproducts are fine, but where's the beef?

Offline

#7 25/6/09 23:43

samanth0r
Member
Registered: 23/6/09

Re: Mouse/Response Issues

Yes! It's working big_smile Fantastic big_smile

Offline

#8 25/6/09 23:55

Gumby
Member
From: Seattle, WA, USA
Registered: 30/8/07

Re: Mouse/Response Issues

WONDERFUL. Ok, this is great. smile


Iritscen: roll
Iritscen: it's amazing this program even works
Gumby: i know
Iritscen: and that statement applies to my code, not just yours

Offline

Board footer

Powered by FluxBB