Oni Central Forum

A forum for the Oni community

You are not logged in.

#1 25/8/17 11:10

tuqqer
Member
Registered: 25/8/17

Error: "You need to selection the installation directory for Oni"

Long-time Oni player from the original days. Played it daily for a decade. Haven't played it for 8 years. Trying to get it to work again, but keep getting the "Alert: You need to select the installation directory for Oni." message. See this screenshot:

(deleted screenshot on imgur)

I own only MBAirs and two Mac Pro towers these days, all running Sierra, and not a DVD slot for miles around. I contacted a nephew in Toronto who still had the original Oni disk, he Dropboxed the contents to me (I used to own two copies myself, I swear on my mom's grave, just ask my long-suffering ex-wife). I've downloaded all of the updates, and followed the instructions (as shown in the above screenshot), run the terminal command, dragged the Oni app into Terminal to link it. But so far, I can't seem to get beyond that error message, which I get when I double-click the bottom Oni application.

I've search the forum and Interwebs; I did find an Oni forum post from 12-4-16 that asks for the exact same help, but still haven't figured out where the directory is, and where to place it.

Any ideas? Thank you.

EDIT: ok, so no links allowed here. Basically the link shows the error message, and all of the Oni files, including Oni app, the Anniversary Edition Setup v1.2.0, How to run Oni text file, Oni extras folder with keyconfig_mac.sit and the Oni DMG as well as the Oni-1.0v1.36 DMG. Hope that helps.

Offline

#2 25/8/17 11:56

Iritscen
Moderator
From: NC, USA
Registered: 22/10/07

Re: Error: "You need to selection the installation directory for Oni"

Hi, this message has been plaguing Mac users in the latest Oni Intel build, but usually it's only an issue on the first run, as long as the app has been de-quarantined.  You need to select the folder that contains the Oni application and GameDataFolder, and then Oni should save that path in its preferences for the future.  (The Oni 1.0 v1.36 is the old Omni Group build for PPC Macs, you don't want that.)


byproducts are fine, but where's the beef?

Offline

#3 26/8/17 20:59

tuqqer
Member
Registered: 25/8/17

Re: Error: "You need to selection the installation directory for Oni"

Ah, that did it. The folder I hadn't tried was the Oni.dmg, and in its first window was a "Oni f" folder, and by dragging that to the main folder, the error message allowed me to point to that (hard to describe without screenshots, but it worked. Thanks!) I'm up and running for the first time in almost a decade.

Offline

#4 27/8/17 8:21

Iritscen
Moderator
From: NC, USA
Registered: 22/10/07

Re: Error: "You need to selection the installation directory for Oni"

Okay, it sounds like your setup may be a bit weird, but as long as it works smile  You do have to install Oni by dragging "Oni ƒ" to your hard drive, but for reference, the final setup should look like this: http://wiki.oni2.net/Oni_(folder)


byproducts are fine, but where's the beef?

Offline

Board footer

Powered by FluxBB