Oni Central Forum

A forum for the Oni community

You are not logged in.

#1 14/12/15 5:17

hinken
Member

.NET error with AE Installer on Mac OS X 10.9.4

Hello, I'm trying to run the AE installer but I keep getting the following error:

.NET, which is required to use this tool, is not installed on this machine. Please download and install it

I downloaded Mono (both the 32 and 64 bit options) and updated Java as well, still the same error. What do?

Offline

#2 14/12/15 11:54

Iritscen
Moderator

Re: .NET error with AE Installer on Mac OS X 10.9.4

Wow, I haven't been running the AE Installer so I didn't catch this before now.  I can reproduce this on my Macs, which are running 10.11.  Mono is installed but not visible to the AE Installer.  I filled out a bug report for Alloc to look into this.


byproducts are fine, but where's the beef?

Online

#3 18/12/15 22:09

Iritscen
Moderator

Re: .NET error with AE Installer on Mac OS X 10.9.4

Okay, I figured out what happened.  The really short explanation is that it has to do with the new versions of Mono (.NET) being installed to a different directory than they used to be.  I didn't think that would be an issue for the AE, but it was.  I have updated the copy of the AE Setup app on Oni Mod Depot to 1.1.8, if you wouldn't mind starting installation again from the beginning and letting me know how it works (it seems to be fixed on my Macs).


byproducts are fine, but where's the beef?

Online

#4 21/12/15 0:59

ntphillips
Member

Re: .NET error with AE Installer on Mac OS X 10.9.4

Thank you!

That worked perfectly (I had the same issue),
FYI, am on OSX 10.10.5, latest Mono/java

Offline

#5 21/12/15 7:35

Iritscen
Moderator

Re: .NET error with AE Installer on Mac OS X 10.9.4

Good, glad to hear it!


byproducts are fine, but where's the beef?

Online

#6 30/12/15 16:21

hinken
Member

Re: .NET error with AE Installer on Mac OS X 10.9.4

seems to be working for me as well, thanks for the help!

Offline

#7 30/12/15 17:00

Iritscen
Moderator

Re: .NET error with AE Installer on Mac OS X 10.9.4

Great, thanks for letting me know.


byproducts are fine, but where's the beef?

Online

Board footer

Powered by FluxBB