Oni Central Forum

A forum for the Oni community

You are not logged in.

#1 28/9/10 8:33

ilovemico
Member
Registered: 28/9/10

No sound and black textures

Hi, i am new here, i come here because i want to play this good game, old but still good.
I remember to play Oni on the PC of my friend, about 3 years ago, and this runs quite good, so i decided to get the game and play it on my PC, so installation runs good, then, when directx 7 was being installed, appeared a window what tells me that "directx can't be installed" well i already have diretcx 9.
I had that error when i run the game, so i've downloaded the *.exe to play it on XP system, all worked fine...
But the game hasn't sound, and it skip many of textures, for example i see Motoko's face all in "black" i mean is like there is nothing on her face, and can't see symbols on consoles and others.
My Pc is old too, but i thing i should play Oni without any trouble:
Hard disk 160 gb ( 50 gb free space)
256 MB RAM
1.8 GHz Intel Pentium 4
nvidia riva tnt2 Model64/model 64 Pro (66.93 i can not install 71.89)"
***also i've tried to install older graphic drivers and the game runs "perfect" ( all textures good ) but still no sound and fps is quite slow sad
What should do i do? Or what i need.
thanks for your time.

Offline

#2 28/9/10 9:35

TOCS
Member
From: Denmark
Registered: 4/4/07

Re: No sound and black textures

Try check if the sound isen't muted in the 'Options'. Also you might want an upgrade for your PC sooner or later. smile By the way, welcome to the forums! smile

EDIT: I think IE9 is the cause of the random HTML code in this post.

Last edited by TOCS (29/9/10 0:44)

Offline

#3 28/9/10 13:19

s10k
Member
From: Portugal
Registered: 14/1/07
Website

Re: No sound and black textures

TOCS wrote:

Also you might want a upgrade for your PC sooner or later. smile

That's not important here because that pc should run oni perfectly. (I know because it is very similar to my old one)

***also i've tried to install older graphic drivers and the game runs
"perfect" ( all textures good ) but still no sound and fps is quite slow
[img]img/smilies/sad.png[/img]

Hm... Try another versions it should fix the fps and texture problem. About the sound I am not sure. Try also update your sound drivers and make sure you have lastest directx. (9.0c in xp)

Last edited by s10k (28/9/10 13:20)

Offline

#4 28/9/10 13:24

Gumby
Member
From: Seattle, WA, USA
Registered: 30/8/07

Re: No sound and black textures

Don't use that EXE. Use http://geyser.oni2.net/EXE/pc.east/Oni.exe and http://rossy.oni2.net/files/daodan/binkw32.dll.
Where did you get the EXE?


Iritscen: roll
Iritscen: it's amazing this program even works
Gumby: i know
Iritscen: and that statement applies to my code, not just yours

Offline

#5 28/9/10 15:21

ilovemico
Member
Registered: 28/9/10

Re: No sound and black textures

^right now i've uninstalled ONI from my pc, since i can't play it properly sad ( about the exe i think is the same, but the second file, where should do i put this one?
and about the *.exe, mmm... from  here http://oni.bungie.org/help/winxp.html

@Script_10k: when you say "another" you mean i must use spanish ver? oh i remember that aniversary version or something like so ( i take a bit of time to read the forum ) them how i can install that version?
and yeah all fine with directx 9.0c.

As for the sound, i'll try to uninstall my current  drivers and install them again or maybe an update can be usefull as well.

Offline

#6 28/9/10 15:57

s10k
Member
From: Portugal
Registered: 14/1/07
Website

Re: No sound and black textures

I mean another graphic driver versions.

Offline

#7 28/9/10 20:46

Gumby
Member
From: Seattle, WA, USA
Registered: 30/8/07

Re: No sound and black textures

The EXE is NOT the same as the patch you downloaded. That page is ancient and Harry needs to either update it or remove it.


Iritscen: roll
Iritscen: it's amazing this program even works
Gumby: i know
Iritscen: and that statement applies to my code, not just yours

Offline

Board footer

Powered by FluxBB