Oni Central Forum

A forum for the Oni community

You are not logged in.

#1 8/1/10 10:04

karadoc
Member

A couple of problems

I've just installed AE and played it for a few seconds, but I've noticed some problems.

- The controls are far less responsive than usual. Sometimes commands are delayed, and sometimes they don't register at all. (jump, punch, kick, crouch). Also, I need to move the mouse much further than normal to turn around.
- The hook kick special move was unlocked from level one. (left/right, forward+kick) It should only be available from the Rooftops level. (I didn't install either of the move-unlocking mods).

Here's how I've got the game set up:
Mods installed:
- Brutal AI
- Dangerous Glass
- Dashing AI
- Glass Breaking Moves
- Improved Weather
- Knockdown Revamp
- New Characters
- New Weapons
- Shinatama Too
- Upgraded ONCCs
- Weapon Improvement

When I started the game I immediately switched to 1280x1024 resolution. I'm running Windows 7.

I don't really feel like uninstalling each of the mods one by one to see what's causing the problems, so I'll probably just go back to playing the unmodded version. (The unresponsive controls make the game practically unplayable.) I'm mostly just posting so that those of you who are working on these mods will know about the problems.

Last edited by karadoc (8/1/10 10:13)

Offline

#2 8/1/10 11:31

Tudorge
Member

Re: A couple of problems

I don't know. The only problems I have are just effects that don't appear and bad texture quality at any setting. It could be one of the modifications that modify the .dat files (video).
The unresponsiveness hmm, it shouldn't happen. Try contact the creators. (gumby?)
I also have the same problems on a laptop, I thought they won't appear on it, but they did the same symptoms of bad video as on desktop. So my video card is safe big_smile.
Oh, it may be the upgraded onccs (i don't know where they come from) because they edit controls.
Try solutions in this order:
1.Set resolution to 800x600-32 or lower.
2.If the AE installer did not used this: use daodan.dll (http://wiki.oni2.net/Daodan_DLL)
3.Try to lower detail level, it may be a memory problem.
4.Re-install AE but deleting all related files. Clear IGMD folder inside Edition\
5.Try using the fixes of compatibillity in win7. I have it on my desktop and I didn't percept any other problems.
6.***Last*** Clear modifications, clear files, clear everything. Reinstall Oni, reinstall aE, globalize files. Then test with the fewer feautures possible.

Oh, I need help too. My laptop does show the same video problems as my desktop only in aE. I usualy play normal oni but when i want all the moves and a few more weapons to test my project, i need it. Mostly for the glass and moves and weaps.
But the curious thing is, when i start aE, i don't see the version number, and the aniversary edition text you see when you start oni (with ae). It starts like the normal oni.

Offline

#3 8/1/10 16:10

Gumby
Member

Re: A couple of problems

What are your system specs?

Also, the "hook kick" is a bit bugged. I never could figure out why it insisted on unlocking itself...


Iritscen: roll
Iritscen: it's amazing this program even works
Gumby: i know
Iritscen: and that statement applies to my code, not just yours

Offline

#4 8/1/10 18:00

Iritscen
Moderator

Re: A couple of problems

This isn't a vsync issue?  I thought that was what caused delayed controls.


byproducts are fine, but where's the beef?

Offline

#5 8/1/10 18:38

Gumby
Member

Re: A couple of problems

It is likely a vsync issue, but could also be a performance issue.


Iritscen: roll
Iritscen: it's amazing this program even works
Gumby: i know
Iritscen: and that statement applies to my code, not just yours

Offline

#6 8/1/10 19:48

karadoc
Member

Re: A couple of problems

Ok, here's what I've found out. I reinstalled AE with none of the optional mods. The controls were still unresponsive and the twister kick was still unlocked.

Changing the resolution down completely fixed the controls - but on closer inspection it isn't the high res causing the problem, but rather full screen mode. ie. regardless of the resolution, it works well while windowed, but doesn't work full screen.

My computer is a meat-axe - it should be able to handle it. (Radon 4890 GPU, core i7 CPU, 6GB RAM). But I can hear the computer working much harder while running full screen mode (I can hear the fan). The problem doesn't exist in the non AE version.

I don't know much about this game, but I suppose it could be a vsync problem if for some stupid reason the game doesn't listen to the controls while it is waiting for the vsync... I'm not sure how to turn that off anyway. It doesn't seem to be in the game menu and I don't know how to change it out of the game either. My old computer had a program which let me choose a bunch of GPU settings on a game-by-game basis, such as vsync and anti-aliasing; but I haven't seen a similar tool on this computer.

By the way, I reckon being able to alt-tab out of the game is probably my favourite feature that the AE adds. smile It often annoyed me that I couldn't do that in the normal version.

Offline

#7 8/1/10 20:25

Gumby
Member

Re: A couple of problems

Your computer is too powerful. The timings are getting a bit screwed up I think. You actually need to force Vsync in your ATI control panel.


Iritscen: roll
Iritscen: it's amazing this program even works
Gumby: i know
Iritscen: and that statement applies to my code, not just yours

Offline

#8 8/1/10 22:53

karadoc
Member

Re: A couple of problems

I think you were right. Telling the GPU to always use vsync fixed the problem with the controls. Thanks. smile Now I can enjoy the benefits of AE.

Offline

Board footer

Powered by FluxBB