Oni Central Forum

A Community-driven Forum discussing Bungie's Oni

You are not logged in.

#26 22/8/12 8:34

Samer
Member

Re: Konoko HD Problems discussion

Iritscen wrote:

I know the UV map is different, but it shouldn't matter because Oni almost always draws characters at LOD 5 -- the forcefield will use the lower LOD, but it won't be noticeable at all that its UV map is different since it's only got the shield texture.

that's not happening when hd konoko is used it's either using lod 3 or lod 2, rarely lod 4, never lod 5 .. Typing chr_lod = 5 gives nothing even though i've set 5 lods in the xml .. Lod 5 doesn't change anything while 4, 3, 2 and 1 do. And when using forcefield it's not using lower lod it's using the lod currently used for model, if it's lod 2 it uses forcefield lod 2 if lod 4 usues forcefield lod 4. Are u sure that the forcefield uses lower lod or is just a theory ?


Well, motion blur is infrequent, so that sounds good enough to me

ppk, crescent moon kick, rising fury, devil spin kick, twister kicks (almost half her moves) all have motion blur and with the AE dashing blur it's even worse, and should mention that not only it happens if the character uses a move while wearing the forcefield but if any other character does a move with motion blur .. Like if u're fighting a ninja using hd konoko and it a does shadow dash, or a fury with whirl kick .. Etc .. then the forcefield flickers and hit impacts disappear or if there's a character using phase cloak or if there's another hd character (another konoko hd or even a corpse)

but I'm certainly not going to tell Gumby that he can't raise the buffer size using the Daodan DLL.  It's just that then we have to ask Feral to raise it on the Mac side... and where do we stop?  If we raise it for a couple existing mods, the next modder will ask us to raise it a little more for their mod.  Oni's engine isn't optimized well enough for such high-poly characters to begin with.

seriously what other modders tongue leucha is the only one who have attempted to make hd character models, griffin and muro don't come close in polycount, and i fail to see the downside, isn't the AE supposed to improve the game continously and make more room for modders, we can stop when it affects the game negatively, i'm wondering on what basis were they increased in the first place ? Why was that limit chosen and not higher ? Were there trial and errors to see the max or was it that simply there was no need for higher limit at the time ?
And again not asking to increase them by a lot, only so HD konoko (the only real full body HD character we have and i think will ever have, works, cz well it's konoko hmm) my models are always lower poly, unfortunately.I struggled a lot to make the female bgi boss work. So if u can make it easier for us modders then why not, modders who are working on character models are limited, besides myself, leucha's only mod, VR and you recently .. Who else is ? And at least increase them so the claim the AE currently has works, it's said that the limit on body parts is 1024 .. I decreased the head to 1020 and no other body part has more than 800 .. Yet it's causing buffer overflow.

Samer, you've set variables before on the console line, haven't you?  That's just the standard feedback telling you it accepted your command.

oops sorry my bad, i suck at commands and bsl, the only one i ever use is co display and set class, i didn't notice the lod on the top right side of the screen.

problem is in game it rarely ever uses the lod 5 that i made even as player, it appears then immediately switches to lod 4 ..
Okay, that's peculiar.  Let's investigate this some more.  I'll have to think about what might cause that.  Is this happening without the force field on?

actually what i thought was lod 5 wasn't.. When i type show lod it says lod 4 .. So it never uses lod 5, rarely lod 4, usually 3 or 2 rarely 1, if i type chr_lod = 5 nothing happens .. If i type 4 it switches to 4, that's why i'm asking why are there 5 links as it seems lod 5 isn't used at all

in the xml i set
link 1 : model lowest
link 2 : model low
link 3 : model medium
link 4 : model high
link 5 : model highest

in game link 5 acts as non existant, setting chr_lod = 5 gives nothing while setting chr_lod = 4 gives link 4 model

so i set it to
link 1 : low model
link 2: medium
link 3 : high
link 4: highest
link 5: highest

now weirdly it doesnt consider link 1
chr_lod = 1 gives me the link 2 model chr_lod = 2 gives me link 3 and chr_lod = 3 gives me link 4 model and chr_lod = 4 gives me link 5

and it immediately switches to lod 2 or 3 giving me the lower poly model, forcefield or not.
so the only way i was able to have it automatically use highest model was to se this
link 1 low
link 2 medium
3, 4 and 5 highest

now it acts as link 2 is lod 1, link 3 lod 2, link 4 lod 3 and link 5 lod 4
while link 1 acts as non existant, and it doesn't use lod 1 except if i manually set it .. Spawning AI uses lod 2 3


i got to say this has become frustrating and i'm going to release as is, at least forcefield covers all body and hit impacts only disappear if :  player forcefield   motion blur on any character, or player forcefield and another hd character exists on screen whether alive or corpse, or player forcefield and phasecloak on any character...

so after i release i hope someone tries and works on it, as i think this is a community mod and not just 'my mod' and I've done all i could do .. Decreased the model polycount many folds from original HD while maintaining the ''HD look''

Last edited by Samer (22/8/12 8:53)


Join our Oni Facebook Group
Check My YouTube Channel for my Oni Videos.
Check My Wiki page for all my stuff

Offline

#27 22/8/12 12:59

Samer
Member

Re: Konoko HD Problems discussion

2012-08-22_205525.jpg


Join our Oni Facebook Group
Check My YouTube Channel for my Oni Videos.
Check My Wiki page for all my stuff

Offline

#28 22/8/12 13:40

EdT
Moderator

Re: Konoko HD Problems discussion

Samer: chr_lod starts at 0 and goes to 4, that accounts for your 5 slots.

Offline

#29 22/8/12 15:35

Iritscen
Moderator

Re: Konoko HD Problems discussion

Samer wrote:

Typing chr_lod = 5 gives nothing even though i've set 5 lods in the xml .. Lod 5 doesn't change anything while 4, 3, 2 and 1 do.

As EdT said, you are supposed to use values 0-4, not 1-5.  Don't forget that we have this stuff documented on the wiki: BSL:Variables.  Notice that values outside of 0-4 are interpreted as "use auto-LOD".

And when using forcefield it's not using lower lod it's using the lod currently used for model, if it's lod 2 it uses forcefield lod 2 if lod 4 usues forcefield lod 4. Are u sure that the forcefield uses lower lod or is just a theory ?

According to what I've been told, the forcefield should always be the lower number between the body's current LOD and LOD 2, so if the character is at LOD 5, the field should still be LOD 2.  I haven't tested this myself, but what makes you say that the forcefield is always at the same LOD as the model?  Can you really see the difference in detail between LODs when they have the shield texture applied to them?  I would think the only way to tell for sure would be to make a large change in each model's LOD (like one point being pushed out from the head to form one spike for LOD 1, two spikes for LOD 2, etc.).

i'm wondering on what basis were they increased in the first place ? Why was that limit chosen and not higher ? Were there trial and errors to see the max or was it that simply there was no need for higher limit at the time ?

I'm not aware of the limit having been raised.

And again not asking to increase them by a lot, only so HD konoko (the only real full body HD character we have and i think will ever have, works, cz well it's konoko hmm)  my models are always lower poly

So, "We should increase the limit in Oni across both platforms for one mod"?  Repeat this back to yourself and tell me if it makes sense smile  Really, Leucha's work is fantastic, but the simple fact is that he should have used less polys; that was his responsibility as a modder.  Of course, none of us noticed the issue at the time, so we can't really blame him, but it is what it is.

it's said that the limit on body parts is 1024

The limit on what is 1024, now?  If you're referring to polys, the poly limit should be considered to be 2048.  I will always repeat this until I inevitably go crazy one day:

I wrote:

The limit is 2048 vertices/4096 polys per object, whether it be a body part or otherwise.  We sometimes cut those numbers in half when stating them, to encourage modellers to leave room for quick-and-dirty cel-shading to be applied (since it doubles the polys).

However, this is the limit on what Oni will accept as an object model.  I stated at the outset of this discussion that I'm not sure that it really affects buffer overflow in a straightforward, predictable manner, only that lowering the poly count might help.


byproducts are fine, but where's the beef?

Offline

#30 22/8/12 17:15

Samer
Member

Re: Konoko HD Problems discussion

Iritscen wrote:

As EdT said, you are supposed to use values 0-4, not 1-5.  Don't forget that we have this stuff documented on the wiki: BSL:Variables.  Notice that values outside of 0-4 are interpreted as "use auto-LOD".

i thought that so i tried chr_lod = 0 it didn't swtich to 1 .. So if it uses 0-4 shouldn't when i input chr_lod = 0 it switches to the lod 1 ?  Instead nothing happens like when i input 5 only 1, 2, 3, 4 .. Maybe i'm misunderstanding, and i swear i searched the wiki for lod .. All that came up was hex stuff on when lod is changed according to distance. Again i'm no good with bsl so I'm sorry if it's something obvious that i'm not getting.

but what makes you say that the forcefield is always at the same LOD as the model?  Can you really see the difference in detail between LODs when they have the shield texture applied to them?  I would think the only way to tell for sure would be to make a large change in each model's LOD (like one point being pushed out from the head to form one spike for LOD 1, two spikes for LOD 2, etc.).

as i said before, i used modified HD head for lod 5, konoko's vanilla lod 5 for new lod 4, konoko's vanilla lod 4 for new lod 3.. Etc so yes it is very apparent head shape is completeley different, i suggest u take a look at the shape of hd konoko and vanilla konoko to see what i mean. .. When lod 5 or is it 4 now m confused .. When The highest one is used the model has the hd head shape and the hd forcefield headshape if it had that of lod 2 then the forcefield head shape would have been that of vanilla konoko

So, "We should increase the limit in Oni across both platforms for one mod"?  Repeat this back to yourself and tell me if it makes sense smile

i don't know how difficult it is as i know nothing about programming, but me saying that was based on Alloc saying it was increased before, so how hard would it be to increase it again, we've had several bink32 updates for reflective textures so why not. You make it sound very difficult and like it's breaking some pre-set rules.

The limit on what is 1024, now?  If you're referring to polys, the poly limit should be considered to be 2048 ... We sometimes cut those numbers in half when stating them, to encourage modellers to leave room for quick-and-dirty cel-shading to be applied (since it doubles the polys).

so that doesn't make sense if the poly limit is 2048, and half is 1024 so current head shouldn't cause problems at all as it's 1020 polygon yet it does, (lower than half of the limit), and then what did leucha did wrong ? If the limit is 2048 polygon ? He stuck by that none of the parts in his model is more than 2048 poly, head was 1572 .. So we can't say it's leucha's fault since he did stick by the limit, yet it's causing the problems bringing us back to the point of maybe it's not the model's fault but the engine needs that limit increase smile cz maybe that 2048 limit is theoratical and in actual game it's being much less, that's my point, to just make sure that the actual limit in game coincides with the theoritical one.

I stated at the outset of this discussion that I'm not sure that it really affects buffer overflow in a straightforward, predictable manner, only that lowering the poly count might help.

fair enough but what else could it be ? .. The bgi boss i was making caused buffer overflow, decreasing head polycount removed that problem .. Isn't there a possibiltiy that in game the actual limit is not 2048 Poly but much lower ?

in the end as i said i'm not going to work on this anymore, it's frustrating me, I'll release the package as is, the screenshot is above, hopefully someone will either figure out what's causing the buffer problem, or if it's that the poly limit isn't actually 2048 to increase it cz we stuck by the limit, or that leucha would somehow fix the model but I don't see how he would, the only variable in the model is the polycount and the body parts are much lower than the 2048 poly claimed limit,  the head is the only one more than 1024 poly, so what exactly can he do ? Or what exactly can we as modders do to avoid that ?? no one seems to know ...

Maybe in characters it's the whole model poly count that matters not individual parts .. If so someone with engine and coding experience (not me) should expirement and set us the limit cz the one on single object poly limit isn't applying, and in practice lowering the poly count did help, nor did gumby's suggestion of several lods help .. What other variables are there, why doesnt someone test them so we know once and for all ?

edit : i remembered that jubei and akane,and  hayate when i added a swrod on his model (though it was low poly sword) also caused flickering forcefield and disappearing hit impacts (while wearing or not wearing a forcefield), especially if they're on the screen witha high poly model or another character wearing forcefield or phasecloak .. And for those characters the body parts didn't even exceed 1024 poly, yet alone 2048 which makes me further believe that the limit for characters is much lower than 2048 even lower than 1024, or that the count should be measured / model not / body part .. Or maybe like iritscen said there's another variable in the models that we need to figure out, yet from practice i don't think that's it ..

Last edited by Samer (22/8/12 18:12)


Join our Oni Facebook Group
Check My YouTube Channel for my Oni Videos.
Check My Wiki page for all my stuff

Offline

#31 22/8/12 18:13

Iritscen
Moderator

Re: Konoko HD Problems discussion

Samer wrote:

i thought that so i tried chr_lod = 0 it didn't swtich to 1 .. So if it uses 0-4 shouldn't when i input chr_lod = 0 it switches to the lod 1 ?

Okay, it looks like it may be impossible to set the closest character on-screen to LOD 1; there seems to be a built-in exception that forces him/her to use at least LOD 2 or 3.

yes it is very apparent head shape is completeley different, i suggest u take a look at the shape of hd konoko and vanilla konoko to see what i mean.

Hmm, I really thought the forcefield was set to LOD 2 no matter what, but I guess we can consult with Neo and see what he thinks is going on here.

So, "We should increase the limit in Oni across both platforms for one mod"?  Repeat this back to yourself and tell me if it makes sense smile

i don't know how difficult it is as i know nothing about programming, but me saying that was based on Alloc saying it was increased before, so how hard would it be to increase it again, we've had several bink32 updates for reflective textures so why not. You make it sound very difficult and like it's breaking some pre-set rules.

My point there wasn't that it was hard, just that it's illogical to change both Oni apps permanently for a single mod.  We know the game suffers when high-poly characters are used, so why encourage it?  Just for the record, the Daodan DLL never changed the limit(s), and doing so can have surprisingly far-ranging side effects on the engine because of the resulting increase in memory usage and other factors, so it may in fact be hard to change.

so that doesn't make sense if the poly limit is 2048, and half is 1024 so current head shouldn't cause problems at all as it's 1020 polygon

And how many vertices does it have?  Why haven't you mentioned the model's vertex count even once, despite how many times I've stated the vertex limit?

Isn't there a possibiltiy that in game the actual limit is not 2048 Poly but much lower ?

Again, the limit is absolute -- your model will probably be rejected if it exceeds the poly/vertex limit.  We can see the limit as a literal number in the engine, so that's not really a question mark; only the question of how/whether poly/vertex count leads to buffer overflow is really unanswered, and it might take some serious digging to find out.

What other variables are there, why doesnt someone test them so we know once and for all ?

Because it's a major pain in the butt smile  But we can run this by Neo and see what he knows.


byproducts are fine, but where's the beef?

Offline

#32 22/8/12 18:21

Gumby
Moderator

Re: Konoko HD Problems discussion

Just add in the lower LODs, don't worry about how they work. Except under very low performance situations (where you shouldn't be using an HD model anyhow), nobody will see them.


Iritscen: roll
Iritscen: it's amazing this program even works
Gumby: i know
Iritscen: and that statement applies to my code, not just yours

Offline

#33 22/8/12 18:36

Samer
Member

Re: Konoko HD Problems discussion

Samer wrote:

1572 triangle, 943 point to 1412 triangle 853 point

Samer wrote:

I've even managed to decrease the head count  to 1035 triangle, 652 point and still causing buffer overflow and disappearing hit impacts

iritscen by points i meant vertices, maybe i used the wrong term, the final head was 1020 plys, i forgot to see how many vertices it became but definetly less than 600 .. Other body parts vertices count ranges between 60 and 200 or so.


gumby as i mentioned in my huge post tongue i did make and use lower lods, but unlike what u say the were very apparent setting the high lod to lod 5 and lower to 4 and even lower to 3 etc : result it never used lod 5 and model looked ugly.  setting 3 out of 5 lods to the high lod was only way to make it use the high model .. But then it never used the lower poly model in link 1 and 2 nor was the forcefield reduced in either cases.

i'll release them with the different trbs lods i made maybe someone can take a look at them ? Maybe i'm doing something wrong .. Would any of u be willing to do that ?

Iritscen wrote:

We know the game suffers when high-poly characters are used, so why encourage it?  Just for the record, the Daodan DLL never changed the limit(s), and doing so can have surprisingly far-ranging side effects on the engine because of the resulting increase in memory usage and other factors, so it may in fact be hard to change.

ok that i did not know, i agree that if it does have such negative effects that it shouldn't be attempted, but if it doesn't and modern hardware can handle it like alloc said without negative effects then i see no reason why not, if we didnt challenge the engine we would have never gotten the high quality reflective textures ... Don't know how we knew though if it wasn't changed before tongue but i can't argue u know much more about the engine and coding than I do


edit : off topic, but it's hard to get a hold of u gumby, would u consider giving me some tips on how to add damage causing particles to the sword ? On the various characters project,  No one else knows how, and u said u're gonna give us a little tutorial on that before and i'm working on a hayate update.

Last edited by Samer (22/8/12 19:05)


Join our Oni Facebook Group
Check My YouTube Channel for my Oni Videos.
Check My Wiki page for all my stuff

Offline

#34 22/8/12 19:24

Iritscen
Moderator

Re: Konoko HD Problems discussion

Samer wrote:

iritscen by points i meant vertices, maybe i used the wrong term, the final head was 1020 plys, i forgot to see how many vertices it became but definetly less than 600 .. Other body parts vertices count ranges between 60 and 200 or so.

My bad, I missed your mentions of points.  I guess I sort of remember seeing that now, but when I posted I was bothered by your recent response that only mentioned polys and I thought that you were totally ignoring the vertex part of my post.

i did make and use lower lods, but unlike what u say the were very apparent setting the high lod to lod 5 and lower to 4 and even lower to 3 etc : result it never used lod 5 and model looked ugly.  setting 3 out of 5 lods to the high lod was only way to make it use the high model

You *do* have your graphics quality slider turned all the way up in Options, right?

if it doesn't and modern hardware can handle it like alloc said without negative effects then i see no reason why not, if we didnt challenge the engine we would have never gotten the high quality reflective textures

I admit that I haven't tested myself, but I have been hearing that using high-poly models affects Oni's performance.  Oni makes poor use of modern graphics cards, so the game's ability to push large numbers of polys is not equivalent to modern games'.

... Don't know how we knew though if it wasn't changed before tongue

I asked Gumby tongue


Edit: Yes, please upload the model; in fact, if you wouldn't mind uploading the version that has unique models for each LOD, it would be appreciated, so we can see if we also have the problem where LOD 5 is not used, etc.

P.S.: Yay, 4000 posts.


byproducts are fine, but where's the beef?

Offline

#35 22/8/12 22:42

Samer
Member

Re: Konoko HD Problems discussion

just to clarify :
2012-08-23_061556.jpg these are the 4 lods ...
and this is the xml
<Link>konoko_blackopslow1.dae</Link>
<Link>konoko_blackopslow2.dae</Link>
<Link>konoko_blackopshigh3.dae</Link>
<Link>konoko_blackopshigh4.dae</Link>
<Link>konoko_blackopshigh5.dae</Link>

picture 1 is what i get when i input chr_lod = 4 .. it's the blackopshigh5 model in the xml .. link 5
picture 2 is what i get when i input chr_lod = 3 .. it's the blackopshigh 4 model in xml .. link 4
picture 3 is when i type chr_lod = 2 .. it's the blackopshigh3 model in the xml .. link 3
picture 4 is when i type chr_lod = 1 it's the blackopslow2 in xml .. link 2

I can't get it to switch to the blackopslow1 (the first link in xml) typing chr_lod = 0 doesn't switch it
and the game on its own only generates second or third picture not first except if i force it (it generates it then immediately switches it when konoko moves) ..
these are those 5 lods and the trbs ..
https://dl.dropbox.com/u/22609960/lower … konoko.zip

theory: could it be that because the model has high quality textures it automatically switches to lower lod to relieve memory use

I should mention that i was wrong here I didn't try the forcefield in this option because the high model was never given in game so i tried something else, i went back today and re-tested it .. if i force lod 4 getting hd model head, focefield like u said does use lower head .. however the problem is it doesn't use lod 4 for the model on it's own ever.

only way for me to make it use the high model and not immediately switch to lower ones (with vanilla head) was to set this
<Link>konoko_blackopshigh3.dae</Link>
<Link>konoko_blackopshigh4.dae</Link>
<Link>konoko_blackopshigh5.dae</Link>
<Link>konoko_blackopshigh5.dae</Link>
<Link>konoko_blackopshigh5.dae</Link>

setting only 2 of them to blackopshigh5 also made it switch to lower with vanilla head

in this option however it doesn't use the lower forcefield lod (that's what i referred to first time)

should also mention that even when it used lower lod for forcefield and even when using the lod in 4th picture for the model itself .. the buffer overflow problems remained. :s

P.S yes i have slider to highest quality and my video card is NVIDIA GeForce 9800 GT which works fine for other newer games.

EDIT : if u want the ONCC and textures I released the package here http://oni.bungie.org/community/forum/v … 853#p41853
but the konoko TRBS isn't the same in the package as the one in the dropbox link

Last edited by Samer (22/8/12 23:33)


Join our Oni Facebook Group
Check My YouTube Channel for my Oni Videos.
Check My Wiki page for all my stuff

Offline

#36 23/8/12 6:59

Iritscen
Moderator

Re: Konoko HD Problems discussion

Samer wrote:

I can't get it to switch to the blackopslow1 (the first link in xml) typing chr_lod = 0 doesn't switch it

As I mentioned above, it turns out that Oni won't allow the closest character (Konoko) to be rendered at LOD 1.  Even using BSL can't force it to happen.  The second-nearest character is always forced to at least LOD 2.  These were exceptions made for the sake of maintaining a minimum level of graphical quality.  The lowest LODs were mainly intended for distant characters.

and the game on its own only generates second or third picture not first except if i force it (it generates it then immediately switches it when konoko moves)

The game also will not auto-adjust LODs for characters who are standing still, which is why Konoko only switches once she starts moving.  This was also done for appearance's sake.  The mystery is why LOD 5 is not getting used on your computer.

theory: could it be that because the model has high quality textures it automatically switches to lower lod to relieve memory use

No, this is just about performance, not memory use.  Oni doesn't seem to care about memory or even how many frames a second it's drawing; it only looks at the total count of polygons in the scene.  We can see the numbers in the binary that Oni uses, the table ranges from 1500 if the graphics quality is set all the way to the left, to 4000 at the high end.  Again, just for emphasis, this has nothing to do with the object poly/vertex limits.  These numbers are being used as guidelines for determining LODs, and a scene might have more than 4000 polys once LOD-picking and rendering has been performed.

I should mention that i was wrong here I didn't try the forcefield in this option because the high model was never given in game so i tried something else, i went back today and re-tested it .. if i force lod 4 getting hd model head, focefield like u said does use lower head .. however the problem is it doesn't use lod 4 for the model on it's own ever.

Told ya smile  Just to be clear, LOD 5 is the highest setting; chr_lod is simply taking the numbers 1-5 in a zero-indexed manner, so chr_lod=4 is asking for LOD 5.

only way for me to make it use the high model and not immediately switch to lower ones (with vanilla head) was to set this
[...]
in this option however it doesn't use the lower forcefield lod (that's what i referred to first time)

Okay, just to make sure we're on the same page, you realize that you're not actually changing what LOD Oni is using by changing the links, right?  You're just changing which model is in which LOD slot to make it look like a higher LOD is being used.  Ultimately it can only fool Oni so much, since Oni is still getting the actual poly count of each character when computing the scene poly total and ramping down LODs of various characters to bring things into line with its table.  This may in fact be the simple reason why you can't keep Konoko at LOD 5 -- the original HD Konoko mod recklessly used the same HD model at all LODs, so we never would have been able to tell visually that this was happening.

Anyway, I still have to test the files you uploaded, and since they're not in a ready-to-install form, that will have to wait until I have time to put a package together.  But it's possible that we just haven't tested high-poly characters enough, and this problem has always been present.  In the end, I think the answer is still going to be "Don't use so many polys".  We'll have to consider Leucha's mod an exception to the rule, rather than an example to imitate.


byproducts are fine, but where's the beef?

Offline

#37 23/8/12 8:17

Samer
Member

Re: Konoko HD Problems discussion

Iritscen wrote:

Okay, just to make sure we're on the same page, you realize that you're not actually changing what LOD Oni is using by changing the links, right?  You're just changing which model is in which LOD slot to make it look like a higher LOD is being used.

yes i do realize that, that's why i said the only way i was able to make it use the higher model was to put it in the lod 2 and 3 slot ..

Anyway, I still have to test the files you uploaded, and since they're not in a ready-to-install form, that will have to wait until I have time to put a package together. .

the trbs I included in the dropbox link is oni format (it holds the 5 models\lods) .. and i released the package in the separate thread i linked http://oni.bungie.org/community/forum/v … hp?id=2412 .. u just have to put the trbs from the dropbox link in that package and install (cz the trbs in the package only holds 3 of the models) .. i also included the different models used for different lods in dae format to make them easier to look at ... so it is a ready-to-install form tongue u don't have to make another package.

Last edited by Samer (23/8/12 8:20)


Join our Oni Facebook Group
Check My YouTube Channel for my Oni Videos.
Check My Wiki page for all my stuff

Offline

#38 16/9/12 20:16

markminiko
Member

Re: Konoko HD Problems discussion

p.aspx?u=v20_p13_photo_1209170911362105_0.jpg
p.aspx?u=v20_p13_photo_1209170914055637_0.jpg

its mine... 256*256 per pic...

Offline

#39 24/9/12 16:36

EdT
Moderator

Re: Konoko HD Problems discussion

I see the problem, your model for the following LOD has this number of polygons
LOD 0: 7,306
LOD 1: 7,486
LOD 2: 7,464
LOD 3: 7,866
LOD 4: 8,525

Of course you will continue to see buffer overflow.  LOD 0 and 1 should be much lower, 4,000 at the most.

Offline

#40 24/9/12 16:44

Samer
Member

Re: Konoko HD Problems discussion

but it will look horrible if i lower it further sad applying polygon reduction leaves a lot of gaps in the model. i'll try it though.

Last edited by Samer (24/9/12 16:45)


Join our Oni Facebook Group
Check My YouTube Channel for my Oni Videos.
Check My Wiki page for all my stuff

Offline

#41 24/9/12 16:53

EdT
Moderator

Re: Konoko HD Problems discussion

I have a program that can reduce the polygons cleanly, I'll do it and update the mod depot

Offline

#42 24/9/12 17:02

Samer
Member

Re: Konoko HD Problems discussion

ouh cool smile !!! can't we also use that to solve leucha's konoko hd problem ?
and u'll also have to help me with a lower lod of hanako tongue

Last edited by Samer (24/9/12 17:04)


Join our Oni Facebook Group
Check My YouTube Channel for my Oni Videos.
Check My Wiki page for all my stuff

Offline

#43 24/9/12 17:09

EdT
Moderator

Re: Konoko HD Problems discussion

Done: http://mods.oni2.net/system/files/26000KonokoHD_1.zip  Please test to verify it eliminates the issue on PCs.

I can help with Hanako and any other model. smile

Offline

#44 25/9/12 5:44

Samer
Member

Re: Konoko HD Problems discussion

Edt after all this time with konoko hd problems u finally fixed it tongue ! (as far as i can tell i didn't get buffer overflow once in my testing and the shield covered all body and contrails didn't flicker)

:$ here's a list of characters that need that fix :$ i hope u don't regret fixing it now tongue when u have the time i'll really appreciate it

*shinibot's humane outfit
*the blackops konoko and carens .. (they use a different trbs than leucha's) if u want to download the package and use the highest lod-dae to make lower ones

when released, hanako will require it on her outfits, so will hydra and sarai much later on :$

but this is great ! finally we get a non buggy hd konoko !

Last edited by Samer (25/9/12 5:50)


Join our Oni Facebook Group
Check My YouTube Channel for my Oni Videos.
Check My Wiki page for all my stuff

Offline

#45 26/9/12 19:59

Samer
Member

Re: Konoko HD Problems discussion

Ed will u be able to spare some time to help me with the blackops konokoHD and shinibot humane outfit by next week :$ .. and hanako in the 2-3 coming days ? cz i'm close to a hanako release, and i'm going to use the blackops carens and shinibot humane in the mega pack ..
or if the program u're using is free and pc compatible maybe u can send me a link and instructions on how to do it.


Join our Oni Facebook Group
Check My YouTube Channel for my Oni Videos.
Check My Wiki page for all my stuff

Offline

#46 26/9/12 20:27

EdT
Moderator

Re: Konoko HD Problems discussion

I should have time on Friday to work on the models.

Offline

#47 11/12/12 7:01

Romulus
Member

Re: Konoko HD Problems discussion

First post, this high polygon model is very nice! Except for the face, Konoko seems to have a puppy dog like nose and flat lips, which to me is disturbing; in my opinion someone oughta re-do her face texture, and make it look like the anime character seen on the menu, the original model has this flat look with huge eyes, it's somewhat close to the anime character, if only it can be re-done with some proper bumpmaps (I'm not sure about the precise technical term) to get rid of the flat look, it'll be perfect!

Last edited by Romulus (11/12/12 7:16)


Core i3 2100 3.10Ghz | Gigabyte H61M DS2 Rev 2.0 | 2X2GB Apacer 1366Mhz DDR3 9-9-9-24 | Hitachi SATA II 500GB | Gigabyte nvidia GT 240 OC 1GB DDR5 | Realtek HD Audio with Creative X-Fi Mod | Asus P-50GA 500W | Space 703 Chasis | Windows 7 X64 SP1 & Windows 8 X64 in dual boot

Offline

Board footer