Oni Central Forum

A Community-driven Forum discussing Bungie's Oni

You are not logged in.

#1 5/4/11 22:18

birdtone
Member

AE Install on MAC

Hello!  I am running 10.4 Tiger on a G4 mac  PPC (!).  My old machine that is now a dedicated ONI box. 

I am ready to try something beyond vanilla yogurt. 

I have downloaded the Edition-Mac-2010-05a.zip.  Installed the Edition folder into my Oni folder.  Also I downloaded the Mono Framework thing.  The newer version said it didn't support 10.4 - so I randomly downloaded an older version in hopes that it did.  I have MonoFramework 2.4.3 installed. 

Now I am at the point where I need to get the AE Installer going.  And when I click on Edition > Install > Installer - I get the AE icon bouncing in the dock for a moment.  And then it disappears and nothing else happens.  So I can't get that program running. 

What am I missing ?

Thank you kindly

Offline

#2 5/4/11 22:32

Iritscen
Moderator

Re: AE Install on MAC

Can you try something for me?  Enter the Terminal and type 'which mono'.  Do you get any output?


byproducts are fine, but where's the beef?

Online

#3 5/4/11 22:36

birdtone
Member

Re: AE Install on MAC

Last login: Tue Apr  5 20:13:28 on console
Welcome to Darwin!
birdtone-power-mac-g4:~ scott$ which mono
/usr/bin/mono
birdtone-power-mac-g4:~ scott$


Should I be doing some searching on what mono version works with OS 10.4?  I'll see what I can find

Last edited by birdtone (5/4/11 23:14)

Offline

#4 6/4/11 7:50

Iritscen
Moderator

Re: AE Install on MAC

Hmm, mono 2.4 should work with 10.4... not sure if mono is the issue here at all or if something else in the Installer startup process is failing.  You should have OniSplit.exe in your Edition folder.  If you're familiar with using the Terminal, I would suggest trying to run OniSplit using mono.  Just something simple like 'mono OniSplit.exe -help", to tell you that mono is working.


byproducts are fine, but where's the beef?

Online

#5 6/4/11 9:41

EdT
Moderator

Re: AE Install on MAC

If you can't solve your problem, I can pull my old G4 tower out of storage and test it out.  I know it worked with the 1st release of AE.

Offline

#6 6/4/11 12:28

birdtone
Member

Re: AE Install on MAC

Looks like yes - I do have OniSplit.exe in my Edition/Install folder.  I am a novice with Terminal but learning.  So this is what I understand.  The Mono program is to allow the execution of PC programs on OSX.  The AE installer involves such a program OniSplit.exe.  I need to figure out if Mono is working properly and get it to recognize OniSplit.exe. Correct?

here is my terminal output - do I need to tell terminal where this file is located ?

birdtone-power-mac-g4:~ scott$ mono OniSplit.exe -help   
Cannot open assembly 'OniSplit.exe': No such file or directory.

Offline

#7 6/4/11 12:48

EdT
Moderator

Re: AE Install on MAC

You will need to change the directory to where OniSplit.exe is located.

Easiest way is to do this is:
type cd then a space, in the terminal then drag the folder containing OniSplit to the terminal and then press the RETURN key.
The command may look like this:
cd /Games/Oni/install

Offline

#8 6/4/11 13:19

birdtone
Member

Re: AE Install on MAC

Ok - yep I got some output this time. 

birdtone-power-mac-g4:/Oni/Edition/install scott$ mono OniSplit.exe -help
/Oni/Edition/install/OniSplit.exe [options] datfile

Options:
        -export <directory>             Export a Oni .dat file to directory
        -import <directory>             Import a Oni .dat file from directory
                                        Target file format is determined from source files (when possible)
        -import:sep <directory>         Import a Oni .dat file from directory
                                        Create a .dat file that uses .raw and .sep binary files (Mac and PC Demo)
        -import:nosep <directory>       Import a Oni .dat file from directory
                                        Create a .dat file that uses only .raw binary file (PC)

        -extract:dds <directory>        Extracts all textures (TXMP) from a Oni .dat/.oni file in DDS format
        -extract:tga <directory>        Extracts all textures (TXMP) from a Oni .dat/.oni file in TGA format
        -extract:png <directory>        Extracts all textures (TXMP) from a Oni .dat/.oni file in PNG format
        -extract:wav <directory>        Extracts all sounds (SNDD) from a Oni .dat/.oni file in WAV format
        -extract:aif <directory>        Extracts all sounds (SNDD) from a Oni .dat/.oni file in AIF format
        -extract:txt <directory>        Extracts all subtitles (SUBT) from a Oni .dat/.oni file in TXT format
        -extract:obj <directory>        Extracts all M3GM and ONCC instances to Wavefront OBJ files
        -extract:dae <directory>        Extracts all M3GM and ONCC instances to Collada files
        -extract:xml <directory>        Extracts all instances to XML files

        -create:txmp <directory> [-nomipmaps] [-nouwrap] [-novwrap] [-format:bgr32|bgra32|bgr555|bgra5551|bgra4444|dxt1] [-envmap:texture_name] [-large] image_file
        -create:m3gm <directory> [-tex:texture_name] obj_file
        -create:trbs <directory> dae_file
        -create:subt <directory> txt_file
        -create <directory> xml_file    Creates an .oni file from an XML file

        -list                           Lists the named instances contained in datfile
        -copy <directory>               Copy an exported .oni file and its dependencies to directory
        -move <directory>               Move an exported .oni file and its dependencies to directory
        -move:overwrite <directory>     Move an exported .oni file and its dependencies to directory
                                        Overwrites any existing files
        -move:delete <directory>        Move an exported .oni file and its dependencies to directory
                                        Deletes files at source when they already exist at destination
        -deps                           Get a list of exported .oni files the specified files depends on
        -version                        Show OniSplit versions
        -help                           Show this help
        -help enums                     Show a list of enums and flags used in XML files

Offline

#9 6/4/11 16:31

Iritscen
Moderator

Re: AE Install on MAC

Hmm, well mono doesn't seem to be the problem.  I'm having a hard time figuring out what else could be the matter.


byproducts are fine, but where's the beef?

Online

#10 6/4/11 17:43

Dirk Gently
Member

Re: AE Install on MAC

open the AEInstall app and open Console at the same time. Tell me what the error message it gives when it fails to launch.

Offline

#11 6/4/11 20:14

birdtone
Member

Re: AE Install on MAC

dyld: Library not loaded: /usr/lib/libiconv.2.dylib
  Referenced from: /Oni/Edition/install/Installer.app/Contents/MacOS/libwx_mac_richtext-2.8.0.dylib
  Reason: Incompatible library version: libwx_mac_richtext-2.8.0.dylib requires version 7.0.0 or later, but libiconv.2.dylib provides version 5.0.0
Apr  6 18:13:11 birdtone-power-mac-g4 crashdump[420]: Installer crashed
Apr  6 18:13:11 birdtone-power-mac-g4 crashdump[420]: crash report written to: /Users/scott/Library/Logs/CrashReporter/Installer.crash.log

Last edited by birdtone (9/4/11 0:08)

Offline

#12 6/4/11 22:03

Iritscen
Moderator

Re: AE Install on MAC

I might have a fix for this.  I'm falling asleep at the moment, but I will try to get something to you tomorrow.  Watch for PMs.


byproducts are fine, but where's the beef?

Online

#13 9/4/11 0:09

birdtone
Member

Re: AE Install on MAC

mmm - so the issue is the operating system libraries.  Should I be trying to figure out how to get the OS higher?   I wonder how high I can go on a PPC Mac.

Offline

#14 9/4/11 7:02

Dirk Gently
Member

Re: AE Install on MAC

Leopard is the highest you can run on a PPC.

Offline

#15 9/4/11 7:28

Iritscen
Moderator

Re: AE Install on MAC

Sorry, this slipped my mind, but I might have time for it today.  This was a problem that we encountered in testing the original AE Installer, and which I solved before its release.  So now I just need to figure out why the second AE Installer has the issue again.


byproducts are fine, but where's the beef?

Online

#16 9/4/11 20:06

Iritscen
Moderator

Re: AE Install on MAC

Okay, check your PMs for a link to an Installer where I tried to fix the problem.  I can't test for the problem myself, so you'll have to let me know if anything is different with this one.


byproducts are fine, but where's the beef?

Online

#17 12/4/11 23:57

birdtone
Member

Re: AE Install on MAC

Nope - no different.  I will work on trying to get the operating system a little higher
Thank you very kindly for your help.  And all the work you all do to keep this wonderful project rolling.

Offline

#18 15/10/11 9:18

woon
Member

Re: AE Install on MAC

Hi, I'm having a problem that might be related to the one birdtone has.

I am running Mono 2.10.5 on OSX 10.5.8 32bit (intel)

I can't seem to run the AE installer, it always "quits unexpectedly". Mono is working (I used the test you suggested to birdtone earlier), so I'm not really sure what the problem is. I'm not sure how to get a console to see what errors happen when it fails to launch.

When I try to use AEtools to run the installer, I get this message:

LSOpenFromURLSpec() failed with error -10810 for the file /Mothballed/gs/Oni/Edition/install/Installer.app. (1)

Any idea what the problem might be? Thanks!

Offline

#19 15/10/11 9:33

Iritscen
Moderator

Re: AE Install on MAC

I'm not sure if the AETools issue is related to your AE Installer issue.  Let's focus first on the AE Installer.  Console is actually an app in the /Applications/Utilities folder.  If you run the AE Installer and then open Console, you might find an error message.  Make sure you are viewing the Log List and have selected All Messages.


byproducts are fine, but where's the beef?

Online

#20 16/10/11 10:13

woon
Member

Re: AE Install on MAC

Ah, thanks! I got a whole bunch of messages, I can't make any sense of them though.

16/10/2011 15:07:01 [0x0-0x10a10a].org.bungie.AEInstaller[4688] dyld: Library not loaded: @executable_path/libwx_mac_richtext-2.8.0.dylib
16/10/2011 15:07:01 [0x0-0x10a10a].org.bungie.AEInstaller[4688]   Referenced from: /Mothballed/gs/Oni/Edition/install/Installer.app/Contents/MacOS/Installer
16/10/2011 15:07:01 [0x0-0x10a10a].org.bungie.AEInstaller[4688]   Reason: no suitable image found.  Did find:
16/10/2011 15:07:01 [0x0-0x10a10a].org.bungie.AEInstaller[4688]  /Mothballed/gs/Oni/Edition/install/Installer.app/Contents/MacOS/libwx_mac_richtext-2.8.0.dylib: unknown file type, first eight bytes: 0x58 0x53 0x79 0x6D 0x0A 0x30 0x30 0x33
16/10/2011 15:07:01 [0x0-0x10a10a].org.bungie.AEInstaller[4688]  /Mothballed/gs/Oni/Edition/install/Installer.app/Contents/MacOS/libwx_mac_richtext-2.8.0.dylib: unknown file type, first eight bytes: 0x58 0x53 0x79 0x6D 0x0A 0x30 0x30 0x33
16/10/2011 15:07:01 [0x0-0x10a10a].org.bungie.AEInstaller[4688]  /Mothballed/gs/Oni/Edition/install/Installer.app/Contents/MacOS/libwx_mac_richtext-2.8.0.dylib: unknown file type, first eight bytes: 0x58 0x53 0x79 0x6D 0x0A 0x30 0x30 0x33
16/10/2011 15:07:03 com.apple.launchd[180] ([0x0-0x10a10a].org.bungie.AEInstaller[4688]) Exited abnormally: Trace/BPT trap

Offline

#21 16/10/11 12:55

Iritscen
Moderator

Re: AE Install on MAC

Hmm, that's strange.  It's similar to birdtone's issue, but I don't think it's the same.  According to my Googling, that error message only seems to show up when a file has been corrupted.  Often it's a library in OS X that has a problem, requiring an Archive & Install, but in this case, the problem is with the library in the AEInstaller itself.  I'm kind of at a loss, but I would suggest re-downloading the AE from the Mod Depot.

If you're curious to see whether you got a bad install, you can also go into the Terminal and use the command "cksum somepath/Edition/install/Installer.app/Contents/MacOS/libwx_mac_richtext-2.8.0.dylib" and see what it gives you for the current copy of the AE Installer.  I get the number 1901704488.


byproducts are fine, but where's the beef?

Online

#22 16/10/11 16:23

woon
Member

Re: AE Install on MAC

curious, I get 4066574233 34

I will try re-downloading and re-doing everything.

Offline

#23 16/10/11 20:27

EdT
Moderator

Re: AE Install on MAC

I should have reported this earlier, but from time to time AE Installer will crash on me at startup.  I have not been able to isolate the cause.  Here is the crash report:

Thread 0 Crashed:  Dispatch queue: com.apple.main-thread
0   libSystem.B.dylib                 0x91750b41 strtod_l$UNIX2003 + 137
1   libSystem.B.dylib                 0x9175221a atof + 62
2   org.bungie.AEInstaller            0x0002c286 fileToModPackage(std::basic_fstream<char, std::char_traits<char> >&, std::string) + 2355
3   org.bungie.AEInstaller            0x00030fa7 getPackages(std::string) + 780
4   org.bungie.AEInstaller            0x000163cc MainWindow::CreateControls() + 17094
5   org.bungie.AEInstaller            0x000168e7 MainWindow::Create(wxWindow*, int, wxString const&, wxPoint const&, wxSize const&, long) + 115
6   org.bungie.AEInstaller            0x00016a38 MainWindow::MainWindow(wxWindow*, int, wxString const&, wxPoint const&, wxSize const&, long) + 92
7   org.bungie.AEInstaller            0x0001e34e AEInstallerApp::OnInit() + 576
8   org.bungie.AEInstaller            0x0001fa48 wxAppConsole::CallOnInit() + 24
9   libwx_base_carbon-2.8.0.dylib     0x009211fb wxEntry(int&, char**) + 59
10  org.bungie.AEInstaller            0x0001f9a6 main + 24
11  org.bungie.AEInstaller            0x0000ec2f _start + 209
12  org.bungie.AEInstaller            0x0000eb5d start + 41

Also, in the console I got this report:
10/16/11 6:23:18 PM    com.apple.launchd.peruser.502[176]    ([0x0-0xb8eb8e].org.bungie.AEInstaller[41650]) Job appears to have crashed: Segmentation fault

Offline

#24 17/10/11 7:52

Iritscen
Moderator

Re: AE Install on MAC

Yikes, okay.  The thing never crashes for me.  I'll try to make some time to look for that bug this week.


byproducts are fine, but where's the beef?

Online

#25 30/10/11 7:19

woon
Member

Re: AE Install on MAC

Hi Iritscen,

It looks like all it took was for me to redownload the Edition and reinstall everything for it to work fine. Plays beautifully. Thanks for all the great work!

Offline

Board footer